Announcement

Collapse
No announcement yet.

Forerunner 305 "device timed out"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    clearing courses worked

    Thanks for posting this solution. I'd gone a year without being able to sync to TC and my 305 is just about full. I wanted to back up to my Mac instead of relying on what I'd posted to GC. Clearing the courses from the device re-enabled syncing. Yay!

    Comment


    • #17
      Same with my Edge 305. Uploading directly into Garmin Connect works perfectly, 100% of the time so it has nothing to do with my device, computer, hub or cable. It's simply a bug in Training Center but Garmin don't seem to be interested in supported older devices so I wouldn't expect to see it fixed.

      Comment


      • #18
        I get device timed out in Training Center on a Mac with my Forerunner 305 as well. Usually it will always time out the first time, then I just go to the Device menu and select receive from device and usually it will work the second time. On rare occasions it won't work the second time and I unhook the device and reconnect it. Then repeat and then it generally works.

        It seems random, this morning it worked first time. The other morning I had to do it like 10 times before it was able to sync.

        It first started to do this a few versions of Training Center ago (don't remember the exact version it started happening on).

        I don't have an courses on my device so I can't try the course deletion thing.

        Comment


        • #19
          Deleting courses worked

          Deleting courses worked for me - thanks a lot! I didn't even know I had any courses.. must have accidentally created them.

          I have seen the same problem (device connects and starts with "Receiving courses", it gets to 100% and then the "Device timed out, please restart and reconnect the device" message appears) on several different combinations of operating system and TC, all with Forerunner 305 with the latest firmware:

          Windows XP + TC 3.6.5
          Windows 7 + TC 3.6.1
          Mac OS X 10.7.2 + TC 3.2.1

          Besides the above, I've experienced the same thing on several different sites using the Garmin web browser plugin.
          Although I haven't tested uploading to anything other than my Mac after deleting courses, I assume that the Windows versions and web browser plugin suffer from the same bug.

          Cheers,
          Danny

          Comment


          • #20
            Deleting courses worked for me. Also just switched from PC to Mac. Thanks for the help!

            Comment


            • #21
              Deleting workouts worked for me...VERY frustrating problem

              Thanks for the info, it's crazy how poorly this really works and how little has been done to upgrade or improve Training Center. It is nearly identical to when I first installed it four years ago. Now I'm noticing that in some cases it won't display HR data and other charts, yet when I upload to Garmin Connect they are there. They must not be doing much/any testing on the Mac platform.

              Cort the Sport

              Comment


              • #22
                I thought I'd cracked it! I changed by USB hub and when I tried, it dragged in the last 12+months of data within 1 min or so. Just been for a run, "device timed out", yet it works via vmware under vista, and runkeeper and garmin connect. I'd be surprised if it's the device and not just crappy code on the mac software garmin make.

                Comment


                • #23
                  Same with me:

                  Mac running TC 3.2.1 - device times out and won't synch.

                  This also used to happen when I used a PC with TC.

                  The PC also had the issue using Sport Tracks software.

                  The Mac doesn't seem to have the issue when using "Ascent" software - it just takes about a minute (feels like forever) before Ascent finds the Garmin 305 and starts the synch.

                  Anyway - I deleted all the courses as the original poster suggested - and all is well - it just synched to TC. Except... in TC it claims there is no heart rate data available for my last workout - only Ascent can find the heart rate data.

                  All in all, this is very strange - but I'm sort of comforted by the fact that it isn't just me!

                  Given the age of the 305 I would doubt that we will see any updates from Garmin to solve the issue - which is a shame as it is a great little device!

                  Comment


                  • #24
                    Deleting the courses worked for me!

                    Comment


                    • #25
                      Originally posted by TOM.RAINEY View Post
                      Deleting the courses worked for me!
                      Same for me.
                      I was already experiencing random timeout errors before loading courses (I'm using a Mac), as soon as I loaded the first one it became impossible to sync. Had to delete them.

                      I will definitely give up buying a new edge 810, if this is the quality of software Garmin delivers.

                      Enrico

                      Comment


                      • #26
                        Thanks for this, it solved a problem for me that was driving me crazy !

                        Scott

                        Comment


                        • #27
                          Same problems, nothing helps, incredibly frustrating

                          I am having the same problem now all of a sudden. It seems as if this starts occurring after a while (this is my 3rd Garmin 305 already!) as if somehow the software gets corrupted. I've tried all. Deleted all courses > 1 month old, reset the profile, tried downloading new TC (but it is still the same version that I have 3.2.1), nothing works. Stops at 83% or 85%, then the device times out. Very frustrating, drives me nuts. Will not get a new Garmin.


                          Originally posted by ENRIK0 View Post
                          Same for me.
                          I was already experiencing random timeout errors before loading courses (I'm using a Mac), as soon as I loaded the first one it became impossible to sync. Had to delete them.

                          I will definitely give up buying a new edge 810, if this is the quality of software Garmin delivers.

                          Enrico

                          Comment

                          Working...
                          X