Announcement

Collapse
No announcement yet.

Forerunner 210 screen went blank

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forerunner 210 screen went blank

    Hi folks,

    I'm having problems with my 210, I've had it for about 2-3 months and it's been working perfectly so far.

    Today, all of a sudden, as it was connected and charging, I heard the tut-tut noise from the speakers as if a USB device has been disconnected, even though I haven't plugged anything out.

    Then I looked at the Garmin and the screen went blank. I disconnected it, then tried reconnecting, tried holding the light button, and nothing seems to wake it up.

    Any ideas before I send it back to Garmin?

    Thanks,
    D

  • #2
    I'm having almost the same problem. Had the 210 since christmas with no probs. We upgraded to Windows 7 on the weekend and when I went to connect the 210 this morning it all went pear-shaped.

    It connected/uploaded/charged fine until I disconnected it. At which point it started beeping at me saying the battery was low. I reconnected it and the battery totally drained and it switched off.

    When I connect it to the pc nothing at all happens on either the 210 or the pc and I can't switch it on.

    Help?

    Comment


    • #3
      Help! Me too! Just went blank as I was uploading this mornings run. Argh!

      Comment


      • #4
        Mine keeps going blank too for no particular reason. It turns back on fine, however.

        Comment


        • #5
          Hi everyone,

          My forerunner 210 suddenly went blank screen

          How did you solve the problem?
          Thanks

          Comment


          • #6
            Another Blank Screen

            My Forerunner 210 went blank just after connecting it to my PC.

            Cannot seem to turn it back on again. Trying to recharge it ?

            Does anyone have any information how to restart the device and or the reason for this ?

            Comment


            • #7
              I had similar trouble over the past month which i thought was caused by connecting to my iMac and seems to have been rectified by an upgrade of the 210 software to the latest software (2.40).

              However when the above was happening to me over the last month I was able to restart the watch by holding the 'Lap/Reset' and 'Menu' buttons down together for 5-10 secs and then pressing the light button down for 3secs to turn it back on. I pieced together some info from some of the other watch forums here and I think the 'Lap/Reset' and 'Menu' buttons together is some sort of reset and then of course the Light button turns the thing on. I sometimes did this procedure many times before it turned the watch back on so it may not be the right thing to do but it worked for me eventually!

              I do love my Forerunner 210 but, IMHO, it has some stability issues.

              Comment


              • #8
                Hey guys, Spoke with the retailler and they were happy to send back to Garmin, however I decided to upgrade to the 610 and they would deal with return. WOW what a beast the 610 is!!!

                Anyone thinking of buying the 210 should seriously consider going for the 610 it is well worth the extra. I particularly like the ability to customise the displays to suit what you want to see, and the wireless connection to the PC and a much simpler charger !!

                As you can tell I am one pleased user !

                Comment


                • #9
                  I solved my problem by sending it back to Garmin and they sent me a brand new one.

                  The screen going blank wasn't the only problem. The device would lose it's charge completely, even while attached to the charging cable?!?! It would also lose connection to the heart rate monitor and stop showing heart rate.

                  I bought it as soon as it showed up in the local store, but I guess firmware upgrades weren't enough.

                  Comment


                  • #10
                    Originally posted by JMCPSYCHOLOGY@GMAIL.COM View Post
                    I had similar trouble over the past month which i thought was caused by connecting to my iMac and seems to have been rectified by an upgrade of the 210 software to the latest software (2.40).

                    However when the above was happening to me over the last month I was able to restart the watch by holding the 'Lap/Reset' and 'Menu' buttons down together for 5-10 secs and then pressing the light button down for 3secs to turn it back on. I pieced together some info from some of the other watch forums here and I think the 'Lap/Reset' and 'Menu' buttons together is some sort of reset and then of course the Light button turns the thing on. I sometimes did this procedure many times before it turned the watch back on so it may not be the right thing to do but it worked for me eventually!

                    I do love my Forerunner 210 but, IMHO, it has some stability issues.
                    Thanks!!!
                    That worked fine for me after blank screen issue: i connected it to my imac and it turned off. No way to switch it back on again...
                    i did your procedure and it worked on the first try!
                    I am like you: FR210 is really a great watch (i had a polar rsx 800 first but i prefere this one and find it more simple, even if Polar has some good points too) but the charging connector really sucks and the watch seems a bit lunatic

                    Comment


                    • #11
                      My Forerunner 210 went blank too

                      I have tried holding down the page menu and lap reset (which worked a few times prior. Now its completely dead. Only bought two months ago and use 4 days a week!!! Hoping Garmin will replace with better model. I am returning to runkeeper for free, to keep track if this helps anyone whilst trying fix the issue.
                      Best gotta run.....DK

                      Comment


                      • #12
                        Been working great - Until today

                        Bought in the third week of November. I use it 3 times a week for up to 40 minutes each time. So in 8 weeks, approximately 24 uses, today when I attach it to upload I got the blank screen.

                        I tried everything I have been finding in the forums both plugged into the charger and not. It is still not coming back on.

                        UPDATE!! I found instructions here in this thread and it worked!

                        I recommend that for anyone who has found other instructions not helpful.

                        Last edited by deserttrip; 01-15-2012, 02:08 PM.

                        Comment


                        • #13
                          Originally posted by OLISCHE View Post
                          Thanks!!!
                          That worked fine for me after blank screen issue: i connected it to my imac and it turned off. No way to switch it back on again...
                          i did your procedure and it worked on the first try!
                          I am like you: FR210 is really a great watch (i had a polar rsx 800 first but i prefere this one and find it more simple, even if Polar has some good points too) but the charging connector really sucks and the watch seems a bit lunatic
                          Hurray! That worked for me as well It went black as I tried to connect it to my MacBook Pro. Tried the menu+lap/recet for about 10 sec and then the light button to turn it back on. However I had to try three times before it worked. So hang in there if it doesn't work the first time so happy now, really thought it had died!

                          Comment


                          • #14
                            This works .

                            this works!
                            Originally posted by JMCPSYCHOLOGY@GMAIL.COM View Post
                            I had similar trouble over the past month which i thought was caused by connecting to my iMac and seems to have been rectified by an upgrade of the 210 software to the latest software (2.40).

                            However when the above was happening to me over the last month I was able to restart the watch by holding the 'Lap/Reset' and 'Menu' buttons down together for 5-10 secs and then pressing the light button down for 3secs to turn it back on. I pieced together some info from some of the other watch forums here and I think the 'Lap/Reset' and 'Menu' buttons together is some sort of reset and then of course the Light button turns the thing on. I sometimes did this procedure many times before it turned the watch back on so it may not be the right thing to do but it worked for me eventually!

                            I do love my Forerunner 210 but, IMHO, it has some stability issues.

                            Comment


                            • #15
                              Solution to the Blank Screen Problem

                              I had the same problem.

                              Heres what I did:
                              1) I held down start/stop and lap/reset
                              2) Then while holding those 2 buttons I pressed the light button.
                              3) I held all three buttons down for a couple seconds and then let go.
                              4) Then I held down the light button down by itself and it turned back on.

                              -Joseph

                              Originally posted by DAJODJEBI View Post
                              Hi folks,

                              I'm having problems with my 210, I've had it for about 2-3 months and it's been working perfectly so far.

                              Today, all of a sudden, as it was connected and charging, I heard the tut-tut noise from the speakers as if a USB device has been disconnected, even though I haven't plugged anything out.

                              Then I looked at the Garmin and the screen went blank. I disconnected it, then tried reconnecting, tried holding the light button, and nothing seems to wake it up.

                              Any ideas before I send it back to Garmin?

                              Thanks,
                              D

                              Comment

                              Working...
                              X