Announcement

Collapse
No announcement yet.

Garmin Oregon 700 doesn't go to mass storage mode

Collapse
This topic is closed.
X
X
  • Time
  • Show
Clear All
new posts

  • Garmin Oregon 700 doesn't go to mass storage mode

    I have problem with my Oregon 700- it seems to be impossible to conect it to the PC. I have tried differnet cables (including original), differend PC's (mac and Windows) but no result- when I plug in the cable, Oregon starts up in full mode and goes in to charging mode with display on.

    I have tried to push it in to the mass storage mode (Power on the Oregon and continue to hold down the power button for 30 seconds) but it only resets all the settings (factory mode)
    I have tried to do it with and without batteries, with and without memory card, nothing works..


  • #2
    This forum is about Garmin Connect not device issues. Please contact Product Support for help.
    Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
    Previously owned Etrex Legend H, Mio Navman and used Mapsource
    (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

    Comment

    Working...
    X