Announcement

Collapse
No announcement yet.

Trophy Case not updating new personal records

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Trophy Case not updating new personal records

    I have broken my personal records for 1km, 1 Mile & 10Km runs in the past few months, sometimes multiple times and yet these records don't update in my Trophy Case on the GC website. I initially didn't have the 1km section enabled, and when I enabled it, the time it's suggesting was set way back in February. This time has been superseded since then. Strava holds my records correctly and those times have been passed on from my Vivoactive HR, so why wouldn't the GC website display those times?

  • #2
    Garmin Connect only detects new personal records at the moment an activity record is uploaded/imported.
    The issue with having to repeatedly log in to vBulletin from one forum action to the next seems to have been partially remedied, but problems persist with changes to User Settings not being properly committed upon saving, and with page encoding such that em dashes, en dashes, left and right quotation marks, accented vowels, etc. are not rendered correctly in the browser.

    Comment


    • #3
      Maybe that wasn't very clear. I explain further.

      My 10K record has been broken twice since the one that's displayed in my trophy case was added by my device. Both times have been uploaded by my VAHR at the time of the record being set and as part of those running activities, yet the trophy case still displays the older record. My note about it adding the 1km & 1 Mile records was due to me enabling them two records in the trophy case, which were disabled by default. Once enabled, Garmin connect hoovered up what it thought was my fastest 1km & fastest 1 Mile records. However these have both been broken multiple times since those times were set. Therefore, GC should have added my fastest 1km & fastest Mile instead of the two records that have been superseded on more than one occasion. The reason I switched the 1km & 1 Mile entries on was to prove that GC is no longer collecting new personal record data, as if it had, it would have added my latest 1km & 1 Mile records and not times that have more recently been superseded, see?

      Comment


      • #4
        are you editing the activities in anyway? i believe this may cause issues

        Comment


        • #5
          I have the same issue. The only item I track in swimming is longest swim (since the laps are sometimes missed in the pool and don't get me started on OWS). I broke my longest swim the other day and I did not get the "new" record indicator in GC that I expected. I went in and manually changed it.

          This had worked before, I'm not sure when it quit working.

          Comment


          • #6
            Are you using the stock Garmin apps on the watch to record the run, or other apps? I haven't had any records automatically noted since I started using "Running App Professional." I go in and manually tell it to make that particular run a record for the specific distance.

            Comment


            • #7
              Originally posted by Darren-M View Post
              The reason I switched the 1km & 1 Mile entries on was to prove that GC is no longer collecting new personal record data, as if it had, it would have added my latest 1km & 1 Mile records and not times that have more recently been superseded, see?
              It's working for me. To test it, first I went into Trophy Case and deleted my 1mi personal record, and also removed it from my Forerunner 630 (running firmware 7.50). I then went for a run, which of course produced a new 1mi PR (of 8:11.5). I let my FR630 sync with Garmin Connect Mobile and uploaded the activity record over the cellular mobile network, while I was still out there at the park, and confirmed/accepted that new PR in Garmin Connect. After that, I went for another run, which produced yet another 1mi PR (of 7:41.1). As you can see from the screenshots below, I got the fireworks overlay over the Personal Records widget on a dashboard in GC (in my mobile browser), and when I went to the Personal Records page, I can see both the previous PR and the new PR, with buttons asking me to decide whether to accept the new PR or just retain the previous one as the entry on record.



              (In both cases, I ran a little bit more than one mile, so it was up to the FR630 to identify and use the time it took to traverse the fastest one-mile stretch within each run.)
              The issue with having to repeatedly log in to vBulletin from one forum action to the next seems to have been partially remedied, but problems persist with changes to User Settings not being properly committed upon saving, and with page encoding such that em dashes, en dashes, left and right quotation marks, accented vowels, etc. are not rendered correctly in the browser.

              Comment


              • #8
                Originally posted by Nighthawk700 View Post
                Are you using the stock Garmin apps on the watch to record the run, or other apps? I haven't had any records automatically noted since I started using "Running App Professional." I go in and manually tell it to make that particular run a record for the specific distance.
                That's it then. I too have switched to Running App Professional, and it looks like it has been since then that my new records don't get recorded on the GC website. What I don't understand is why it should matter. The data always presents in GC app and GC web in exactly the same way, regardless of the app that recorded it. I switched away from the default running app because it crashed multiple times on one run. As far as I'm concerned the apps will only have one opportunity to let me down and then they'll be binned!

                If it is the reason I'm not getting my records recorded then it's a bit poor, because Strava can still work out that I've ran my fasted time over a given distance and it's a third party entity!

                Comment


                • #9
                  You might want to drop a note to the Running App Pro developer (https://www.rh-sports.at/running/feature-bug-request/) to see if he has any insight for why this might be happening (or not happening as the case may be). He usually gets back to me within a few days (depending on how busy he is, and how much research the answer may need). If he does provide an answer, please post here, as my curiosity is certainly piqued. I'd shoot him the question myself, but I just sent him a question/suggestion about something else, and I prefer to keep it to one thing at a time. ;-)

                  Comment

                  Working...
                  X