This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

The GPS on my Forerunner 45s won't work.

When attempting to start GPS tracking for mileage on my Forerunner 45s, I can't get passed the 'Wait for GPS' screen. It won't start. Then after a long period of time, the screen will just say "auto save" and return to clock face. I have only had this watch for 8 months. The problem began sporadically last month, but now the GPS won't work at all.

  • I got the same issue with my garmin 4 runners 45 in last couple of day. It looks like loading forever at WAIT FOR GPS state when starting a run. 

  • Sounds like you have to update the ephemeris data file. Connect the watch to your computer with the USB cable let it update with Garmin Express.

  • my forerunner 45, won't connect to GPS.  I checked on Garmin Connect which said my software is up to date. 


  • I wrote Garmin Express with the USB cable. Not Garmin Connect.

  • Trux suggestion to update software via USB solved a similar GPS problem I had.  The watch started taking forever (if ever) to latch onto GPS on my typical run.  I just did the update and GPS now comes to life almost immediately.  Thanks Trux.

  • Sorry and thanks,  I will try that tomorrow night. 

  • In fact you need to update the ephemeris data regularly, to keep GPS working smoothly. The easiest way to do it, is keeping Garmin Express running in the background (the default installation), so that the data gets updated each time you charge the watch on the USB port. Don't use a charger, whenever possible, use the USB port for charging. A wall charger may also lead to an improperly charged battery.

  • I did but nothing improved. Garmin Express shows that software version 3.40 is up to date right now

  • Garmin Express shows that software version 3.40 is up to date right now

    It is not a question of the software version, but one of the ephemeris data file. It is called EPO.bin and is located in the folder //GARMIN/REMOTESW/ If it does not have a recent date, then there is a problem, because this file holds the information about GPS satellites and helps the device to identify them quicker. If the EPO file is expired, it may tak tens of minutes before the satellites are locked.

    So if the file is expired, corrupted, or missing, your GPS won't work properly. If it did not update automatically when you connected to the watch with Garmin Express, there may be perhaps no space left on the device - check the folder //GARMIN/Activities, and delete older files to free up some space. It is also possble that the file is corrupted - in that case removing it may pehaps help (keep a copy on your computer!). If not, you'll have to upload one to the device manually.

    Read also the Support page about EPO:

  • Hi, I have exactly the same problem with a 45S, brought via Amazon 6 weeks ago, worked ok for the first 4 weeks and then has stopped finding the GPS, and of course it is past the Amazon date for a refund which is really frustrating. If I look in the RemoteSW file there is a file called CPE.BIN  not EPO. Garmin Express has updated the software on the 45S and the CPE.BIN file is minutes old, yet it still cant find GPS.  Any advice please, also, how do I return this advice which should have worked for more than 6 weeks before stopping, Amazon say it is past there returns date.