This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Sync 'failed' after SW 3.9 update

Hi! After the latest update, my watch stop 'syncing'. There is still a green circle, but when I click on the device and attempt to sync, it fails all the time.

Activities are still being tracked, so are notifications. But the changes I made via app such as moving the widget around does not get reflected on the watch.

I have. Restarted the phone, switch on/off the Bluetooth on the watch itself, tried syncing via the watch too.

Kindly advise

Thank you

  • hei there, I'm in Indonesia, but I can't update my vivomove style to 4.7 version. at the moment I'm stuck with 4.0 version. is there a way to update the software?

  • The updates are not released at the same time to all regions where Garmin products are sold. This is due to necessary localization of the SW. If you have tried to update with Garmin Express and it still does not show an update available, you will have to wait.

    Sometime there is a delay between when an update is available and when it is pushed to the watch through the Garmin Connect app. However, updates are generally available through Garmin Express almost immediately after release. Hence my suggestion to give a try to the update through it.

  • Ver 4.7? I have been waiting since 3 months ago... I still don't understand the huge time gap in rolling out firmware for different regions. A few day or weeks are fine I guess, but after 3 months still no changes is simply mind blowing. 

  • my version is still on 4.0, I don't even get 4.5 version yet.

  • I just checked with Garmin Express on my PC and it tells me I am up to date with Ver. 4.5

    I am in the US, so it seems that even on the home market the deployment of 4.7 is still in progress.

  • Did you manage to fix the issue? Have you updated it? I'm using Style v.4.0 (latest - ASIA). Having the exact issue as what you described. The only temporary fix for now is to restart it by charging. 

  • Yep, resolved by replacing it with Instinct 2... Stuck out tongue winking eye 

  • I haven't found a workaround for this yet, but sometime turning off and on the bluetooth make the sync work again. IMO, It's not major problem, because the only thing doesn't sync is the watch face. everything else is working fine.

  • For mine, activities, heart rate trends and sleep tracking don't sync

  • oh yeah, activities is not sync, but you still can see your heart rate on the phone. After synchronization, everything is updated as it should.

    I think 4.7 version solve this problem, but apac version still don't get the update.