This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Connected GPS issues

Former Member
Former Member

Since May 2nd I don't get a map or only a partial map after saving a connected GPS activity. I haven't changed anything in my settings and I always wait until the watch announces GPS ready. Anybody else experiencing this issue?

BTW: I use an iPhone XS with latest iOS and latest GCM app.

  • How do you wear your watch and where do you carry your phone? If the phone is on the opposite side of your body and bluetooth connection is obstructed, the map can be incomplete. I used to have this issue when I carried my phone in a waist pouch on my back; now I have it on my arm (same arm where I wear my watch) and had no issues for a very long time.

  • Former Member
    0 Former Member over 4 years ago in reply to thr4

    Well, I haven’t changed anything so I still wear my wacht on my left wrist and carry my phone in my left pocket. I had no problems at all until a couple of days ago.

    I wonder if the latest GCM caused this issue. I love Garmin hardware but the software...

  • I just tried it today (as I normally don't run with the vivomove) - phone on upper left arm, watch on left wrist. No issues with Connected GPS. Latest app version and watch software, iPhone 11 with latest iOS. Try it with different positioning at least for a short walk/run (for example holding phone in hand).

  • I'm a new Vivomove user and over the last week I've noticed the same issue. The map that Garmin produced was just a straight line between the two balloons. Very short distance. Actual distance covered I added painted in red. I've tried 3 different walks all with the same result. I have the most current versions of all software. If I use the Fitbit Mobile Track on the phone it maps out perfectly.

    Any thoughts?

  • In my experience the Connected GPS depends most on the quality of connection between the phone and the watch. I had zero issues lately but I always carry my phone in a holder on my upper arm and I have the watch on the same arm.

  • My watch and phone were never more than an arms swing away from each other... Unless I have to have them touching I can't get them any closer. Not sure why the GPS has to be sent to the watch anyway. Would be better to just let the App work out the location and map.

  • Hi, my girlfriend has a same problem. I try to every setting in phone battery management for garmin connect, but without good result (only a part of tracking on the map and sometimest without map). Se has samsung A7 (2018). In strava aplikacation work gps tracking correct.

    2 time i try connect the watch to my phone huawey p20pro and GPS tracking works perfect. Resul track is same like from my fenix 6.

    It looks the problem is somewhere betwen the mobile and the watch. Maybe in bluethoot of mobile. I keep mobile on the same site like the watch.

    Have you any idea or advice ?

  • Ok I went for a ride yesterday. Selected Ride from my activities and connected to GPS. Phone was in a holder on my handlebar. My actual ride was for just over 26 minutes and distance was right around 4.5 miles.

    The activity logged my heart rate for the entire time, but GPS shows a very short .12 mile ride. Obviously disconnected right after I started, although it shows on the phone that I'm sending GPS date to the device. I even turned off the battery optimization on the phone to make sure the phone wasn't turning it off.

  • I've had the same issues in the past and I can also confirm that it was communication issues (Bluetooth).

    I have solved them by removing all battery optimization from the concerned app (GC) AND also system apps related with Bluetooth communication (search Bluetooth or something like that).

    Just consider that after an update on the phone the settings of the battery optimization might be reseted.

    I also activated the "lost connection warning" from the VM. I think also helps to keep the connection awaken but that's just a feeling.

  • Thanks Jordi, I've looked everywhere in the settings for battery optimization and everything I could find was set for no optimization. The GC app is specifically set for NO optimization as well. I'm wondering if it has something to do with the screen going dark... I'll have to check that. It's funny that I can start up my old Fitbit app and start a mobile track activity and I get the entire track without any issues.

    I'm going to have to play with it some more. I think I also have another issue that I have to work out. Setting up a walking activity without using the GPS is not using my input stride length, haven't worked out what SL is being used yet but I will this weekend. 

    Thanks again.