This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Connect App not finding Index

It seems this conversation is very common, however, I am not finding anything that pertains to my specific situation.

Upgraded my wifi network recently with the eero mesh wifi. Love it by the way, if anyone is looking.

Went through and reconnected all of my home wifi devices. I didn't change the SSID, so there was a lot of "forget network" steps. Also, the eero does not let you select the private network, so I had to adjust everything from 192.168.1.x to 192.168.4.x. Not a big deal.

Unfortunately, the Index is the only device giving me a problem The mobile app just doesn't want to see it.

I've removed it from my account, pulled the batteries for fresh ones, restarted the Connect app, restarted my mobile device, leaned on the reset button on the bottom of the Index.

What remains is a mobile device that cannot find the Index and an Index with a Wrench symbol and a flashing wifi symbol. No ANT+ or Bluetooth symbols.

All feedback is welcome. Thanks in advance!

  • Oh, for the love of all that is holy! Using a Guest NetworkGenius. Joy
    I have been dealing with this issue with my FR630 since v6 of the Eero software/firmware was released back in Oct 2020. I had searched high and low and found reference to disabling Advanced Security on the Eero (which worked), but this is the first I'd seen of using a Guest Network.

    Still frustrating that Eero and Garmin can't work this out (mostly Eero). I'm going to report this workaround on my Reddit thread. So happy to be able to not have to disable/enable Advanced Security EVERY time now. So cool.

  • I have the same problem. I can get the wrench icon but Garmin connect cannot find it via Bluetooth. I've reset it and tried connecting it but it just stays in the renxh mode. 

  • I figured ours out, finally. Tried setting it up with three different iOS devices, two iPhones and one iPad, even uninstalled & reinstalled the app, and had the same problem on all of them, only the bluetooth and wrench icon showing, "Device not found" on the iOS devices.

    I had to shut off bluetooth on all three of the iOS devices, then using the Garmin Connect app an Android device, the scale told me it was already linked to an account, and had to be reset. Apparently resetting it with the button on the back doesn't factory reset it or unlink it if it's linked to an account. I hit 'Yes' on the Android device to reset it, and then it set up normally.

  • That worked like a charm!  Thank you.  I have been dealing with this for a couple of days.

  • it worked! thanks (Index scale v 3.20 firmware).  Nice!

  • And Garmin instructions didn't mention anything about pressing reset in the boot up.. Thank you.

    It just says that those all should blink, that's probably the first setup and next setup requires this thing. Don't know what the reset then does it it doesn't reset really.

  • I have been struggling with this piece of crap for some years. I was lucky to get it connected to my wifi initially after 1 week. Now it has suddenly stopped - no connection to wifi. I have tried even to set up an AP without password - no success. Now I will throw it in the waste for recycling. Never ever I will buy anything from Garmin. When I am going to change my smartwatch it will be another brand for sure. What I understand is that Garmin totally does not care at all about customers and made a similar Index scale with same problems.

  • My scale stopped syncing at the same time Frontier added an eero 6E as a gateway to my existing eero mesh network.  Frontier disabled the Advanced Security (which I had not selected or paid for) on their end.  Now the Index scale syncs and is found as a device.