This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Index no longer measuring metrics

Since April 1st my Garmin Index scale no longer measures any metrics other than BMI - ie body fat %, muscle mass, bone mass etc. After taking my weight it shows the BMI icon with a tick mark at the same time as the upload arrows animate across the top. Then the remaining icons with a X indicating a failure. shows only weights since 1.04.

I've tried a factory reset, two sets of new batteries (ENELOOP) and reconnecting it to my Garmin Connect account. I've yet to try non-rechargable batteries to see if it's a question of voltage.

Anyone have any thoughts on how to resolve?

  • +1

    I have the same problem

    if someone has a solution, please share it

  • Same problem here. For the past 2 weeks only weight and BMI are recording. Then it’s the big “X” for the rest of the stuff. 
    tried new batteries, cleaning the scale surface really well, and resetting the scale.

    And, of course, I’m on the most recent firmware.

    I've had this happen before with low batteries, but that doesn’t seem to be the case this time.

    I'm hoping posting this reply will bump up this topic to allow for some new discussions for a fix.

  • No change at my end since April. I did read somewhere that caloused feet may increase impendance and drive problems with the reading, but I haven't got around to doing anything about mine. I'll report back if anything changes.

  • Having the same issues too

  • I have the same problem and Garmin replaced my device with a new one.

    I'm from Russia, first checked everything according to this instruction (does not work), and then contacted

    I received a response that it looks like I need to change, but I'm from Russia, and I was asked to contact a local representative (Navicom).

    As a result Navicom replaced my scales

    Perhaps this information will be useful to someone

  • As of last week, my scale started measuring the other stats again. The only things I tried was:

    replace the batteries, cleaned the glass very well, pressed the reset button

    After doing that, there still was NO change. After about 2 weeks, it started working again. I’m away for the next month, so I’m curious to see if it’s still working when I get back home...

  • Having the same issue here.  Everything was working fine on August 31.  Now it will only give me weight and BMI.  Big X on the other stats.  Replaced batteries, removed from Garmin Connect, re-connected and reloaded profile, but still won't measure the other metrics.  Current firmware on scales and on phone/App.  Disconnected Garmin Account from My Fitness Pal but still won't display the other metrics.

  • Same problem: what is the slution?

  • Garmin Index S2, same issue. weight, BMI and weather are displayed but not other metrics body fat, muscle bone water. Only different is that it is not showing big X.

    I did replace the battery but it remains the same.

    Any solution for this????

  • I opened mine up today (it's out of warranty so who cares), two cables going from the motherboard to the resistive glass plate were detached (yellow and red at the centre of the photo). I'm going to try solder them back, should solve the problem.

    What gets me is how this happens. There is no relative movement inside, the scale hasn't been thrown about, must happen from vibrations alone.