This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Index Scale no longer connects

Has anyone fixed this yet?

I‘m unable to connect to WiFi. 
Tried all the suggested fixes splitting the WiFi signal, using the stick, using hotspot, resetting etc. 

Something clearly happened a couple of weeks ago. 

Come on Garmin the forum is littered with dozens of similar posts. 

  • Things are just like you described them! Top WiFi icon blinking, I see my weight and all the rest, I don’t get to see no >>>>>> and no x nor Heavy check mark️at the end. No data uploading on Garmin Connect. I am really so frustrated, I don’t know what else to do. I have removed the batteries, removed the scale from my account and added it back, moved it closer to the router, restarted the router, turned off and on the Bluetooth, I can’t get it to sync no matter what I do..

  • Try deleting and reinstalling the app, and then re-connecting the scales. That’s what eventually worked for me.

  • Will try that too, thanks. Although I'm afraid it has to do with the DNS. Maybe I will need to make that change from Cloudflare to Google. Everything I have tried so far, results to the scale syncing just for a day. Next day it fails to sync again. And the top part of the wifi icon is blinking.

  • I'm among those who had to change DNS to to get my scale to work (back in March). I recall looking to see if it was on my network, and not seeing it. I've had some WiFi issues with signal strength to the location of the scale, so I always bring it out next to the router when I'm trouble-shooting. Once it's working, I take it back and it's usually OK. (TMobile micro-cell device was saturating my WiFi and making router much less sensitive until I moved the TMobile thing farther away.)

  • I changed the router settings, it was in dynamic DNS by default and set it to static (Google DNS), and it seems to work fine. I hope I won’t be having more syncing problems because I was really ready to throw that scale away!

  • Thanks AMChortlton!

    We moved and with the new Arris cable modem router all other devices had successfully connected to 2.4 / 5 Ghz WiFi. Reading tips here I tried changing WiFi settings on router to no avail. I was using Connect app on my Android mobile phone and message displayed was Connection is taking longer than usual, try again. WiFi SSID is exactly 10 characters and router was configured to us ISP's automatically assigned DNS servers. I installed Connect app on my iPad and paired Index with it. Vola, Index connected straight away Slight smileSlight smile

  • Great. So for the rest of us trying to get this scale to work again all we have to do is move to a place with a new internet provider and buy a new router. That seems to be the only thing that works. Perfect fix! Thank you Garmin...

  • After I've got my scale to work again using the same steps that some people reported here. But I didn't change any DNS address or SSID name up to 10 characters, neither need to change internet provider. I've just set a new channel on my router up to 10. Some equipments that uses wifi connections don't work if the channel is set above 11 when using a 2.4GHz network. After doing this, the scale recognised the wifi immediately and I could sincronize as usual.

    Before all of that, I've downloaded the latest version of the app (4.34 for iPhone) that was released a few days ago.

    I hope that helps you guys!

  • PI-Hole and Unbound, zero problems after that and very fast. 

  • I did all that and still doesn't work. After removing the batteries, pressing the reset button for a minute, deleting and reinstalling the app, pressing again the reset button and now trying to pair my smart scale still ends up with the same screen... just the wrench and the wi-fi icon blinking. I understand that the bluetooth icon should also appear at this moment, right? Any ideas?