This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin Index Scale Wifi Connection Fail - Resolution

Regarding the much discussed but rarely solved problem of failing to connect a Garmin Index Scale via WIFI: I have Garmin Index Scale which was happily connected and working properly on a Router A.  Then I changed routers to Router B and the scale refused to connect via WIFI and upload data.  Actually I went through the process of connecting the scale via the mobile app, then would use the scale, the wifi icon would blink continuously and the data would never upload to my account.  I tried reseting, factory reseting, fiddling the modem settings, verified I was using WPA/WPA2, used the same password as on the working setup.

Then I tried shortening the network name to 10 characters.  That shorter network name was all that was needed and now the scale connects correctly.  I find it rather shocking that Garmin has nothing on their website support section about character count limitations or whether special characters are allowed in the network name or password.  This would be very easy for them to do and clearly their software does have a serious and not obvious limitation here.

  • I created a post.  Here's what worked for me.

    After reviewing and trying what has been suggested - nothing worked for me. 

    I was able to pair and see network traffic passing, however, no data was being uploaded.  

    My network leverages DOH for DNS. I turned off DOH for the Index Scale and I am now able to sync with Garmin using traditional DNS.

    I‘m unclear/confounded as to why this “fixes” the problem - Garmin could best answer that