This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

WiFi and Connection issues for the Tech Dummy

My scale does not connect to WiFi and does not send data to GC. It did seamlessly a few months ago, but then all of a sudden it pretty much stopped working and hasn't worked since.

So much chatter on this forum of what is causing the problem and some viable solutions.

The problem is, I am not tech savvy and I do not understand most of the chatter that is going on.

What I would like is:
- Garmin can fix this problem on their side so that ALL USERS will not have this problem anymore.
- send out a STEP by STEP set of instructions that a dummy can understand on how to set your router or what I need to do to fix the problem.

  • Sorry, I accidentally clicked down vote from mobile browser and my fingers aren't really as ginourmous of sausages~ LMAO

    Anyway, this reference to adjusting clocks is really a potential workaround for several.

    Any of you may have an issue depending on your firewall ruleset; if by chance you block traffic at your FW for anything destined to Singapore your Garmin Index Scale will NOT connect to WiFi completely.  The Garmin Connect app will state it has completed the setup of your device; when you back out of the WiFi settings menu to the Garmin Connect dashboard your Garmin Index Scale will flash the WiFi icon and the wrench icon will remain constant.

    I merely unblocked traffic to Singapore in my router and this resolved my issue.

    I'll ad this to the reference where I had intermittent resolution using mobile phone HotSpot and then reconfiguring to home AP WiFi.

  • Check the option to update clock entries for your router as listed above to a US clock & firewall rules if you block specific countries.  My local could be using Singapore for NTP which resulted in my specific issue with WiFi.

    It seems that the Garmin Index Scale must check time first when establishing connections with Garmen Connect servers and if your device cannot reach the because of regional DNS lookups and FW blocking you may have issues.

  • Good morning, I broke my head, I tried to restart several times and it did not connect. When I changed the router channel that was on 12, I changed it to 11 or below, it connected at the same time.