This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Swimming pool length=0 after changing battery

I have my garmin swim almost 2 years.
Software on the device, it is supposed to be updated:
Version: ARV 3.600 ATK 2.100

Date battery changes:
After changing first battery (22-11-2013) I had to remove it twice, because pool length was 0 meters.
I could not change it to 25 meters or just customized, pressing the up or down buttons. I could hear the button sound but nothing changed on screen, just 0 meters on pool length. Buttons did not change any result.
After removing battery, wait 15 seconds and give myself a second opportunity it worked.

Today (04-11-2014) I have tried 3 times the same procedure but it did not work.
Also blue button does not work, just makes the beep sound but it does not enter swimming mode.

Has anyone a similar problem?

Not related with this problem I cannot use Garmin Express ( version) to syncronize with Garmin Connect.
I exit from Garmin Express and start Ant agent. It is the only way to upload the training results to connect.
I have a 310XT and this one has no problem to syncronize with connect.

Again, has anyone a similar problem?
  • Former Member
    0 Former Member over 9 years ago
    Swimming pool length=0 after changing battery

    Maybe the battery you have installed is faulty. Sometimes the batteries in a swimming pool stop in the middle of their functioning. You should get your battery checked up from some technician. Swimming Pool Remodeling Charleston SC provides qualified technicians to solve all your pool issues.
  • I had the same problem, changed it with a Duracell battery and all the problems were gone. The new 'cheap' battery didn't provide enough energy apparently..
  • In this case, Garmin changed the device by a new one and the problem solved. I don't what will happen in a year with the next battery change.
  • I had this problem. I changed the battery and got a file error. Watch still counted laps but once you went off SWIM mode to CLOCK mode the data disappeared, although weekly total still worked. A full reset fixed that but the pool length went to 0. I knew how long I swam for so just used the stop watch. Another good quality battery didn’t fix it and I started looking for a new watch. But I went back into SWIMMING and changed other settings before trying the pool length, and it worked. Fully operational now.