This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Mac not recognising 520+, USB, Mac


I have an Edge520+ and a Mac.

Very occasionally, the mac will recognise the 520+ when I plug in a USB cable, but most of the time it won't. The device charges fine - but the OS doesn't recognise it.

I've tried multiple cables, multiple USB ports, turning everything off and on again, standing on one leg and whistling, turn around 3 times counter-clockwise  - all the usual stuff.

All the cables & ports work with other devices, which leads me to believe that there's a problem with the 520.

I tried Garmin support, but they were no help whatsoever.

Does anyone have any idea as to how to make this thing work? Or should I just send it back and get a Wahoo instead?

  • Same problem here. 520 with 2015 MBP. I also have an Edge 500. It connects fine as a storage via USB. But the 520 just doesn't show up in the finder. The Garmin Express app can't find it either. I'm using the Garmin USB cable came with the 520 packaging. 

  • Garmin = great hardware, but they are totally clueless when it comes to software.   Anyway - I know you said you've tried the cables but every time this happens to me, it's 100% that I'm not using the "Garmin" cable.  Like most people I have a number of charging cables and every other device on the planet doesn't seem to care as long as the ends fit nicely. But for some reason, that damn 520 will NOT show up on my mac unless I use the one that has the "Garmin" stamp on the USB end.   I was fighting this last night and then realized that I grabbed the wrong one. Plugged it in and worked immediately. 

  • My Garmin Edge 530 is now syncing with my MacBook Pro 14 (M1 PRO). 

    I am using a USB dongle to plug in to my Macbook's USB-C port.  I first attempted to connect using two other third-party micro USB to USB cables which didn't work. Then I tried the garmin micro USB cable and now it works. I hope that can help.

  • I'm using the Garmin cable I have and have altered System Preferences as suggested , still no joy. MacBook 'Finder' can see the Garmin 520 Plus, but Garmin Express cannot see it at all. Incredibly frustrating!

  • I had the same problem with my Garmin 1030.  The cable connected to my adapter port on my MacBook hardly ever connected to my MacBook.  I got a usb-c / micro USB cable  This allowed me to directly connect to my MacBook Pro with out using an adapter.  Now I am able to connect to  the Garmin regularly.  The link below is the cable I ordered.

  • I had the same problem with a new Macbook Air M1. My Garmin 520+ was not recognized with the USB-C third-party (UNI accessories) USB-C to USB adapter, but the same adapter worked with an Intel MacBook Pro (same macOS). I tried with the original Apple Dongle and this worked with the M1.

    Very strange but I'm used to this kind of problems with Garmin over the years.

  • I purchased this cable and still have had no luck syncing my 520+.

  • I'm sorry you're still having this problem.  As I mentioned, my unit is the Garmin 1030, not the 520+.  I don't know if this helps, but sometimes when my unit doesn't connect (by showing the cable symbol on the screen), I press the lap button for a few seconds when I initially plug my unit to the cable. It then connects, rather than to starting the Garmin.  This was mention on the forum for the 1030 issue.  Maybe you need to still look at other responses to the Garmin 520+ McBook connection problem.

  • The 520+ is a back-up for my 530. The 530 connects fine the first time. The 520+ (using the same cable that worked for the 530 or using the new USB-C cable) does not work.

    If I think of it the new time I'm near a Windows machine and happen to have the 520+ handy I'll give it a try to see if this is maybe a MacOS issue.

  • I now have tested a numer of adapters with a Macbook Air, M1 and the latest macOS Ventura 13.4. Only two adapters worked with the original Garmin usb-a cable: Anker 555 USB-C hub and the Apple USB-C VGA Multiport Adapter. All the other usb-a to usb-c adapters failed to connect my 520+ with the Macbook Air in mass storage mode. I also tried an micro-usb to usb-c cable but this also failed. Surprisingly, also an original Apple USB-A to USB-C adapter did not work.