645M 5.90 Really bad GPS tracks

As in the title, I updated to the 5.90 firmware two runs ago and both of them have been abysmal when it comes to GPS track accuracy.

The watch has been reset to default settings after the firmware update and I selected the same settings as before:

- Smart Recording (1s recording doesn't change the accuracy, tested it)

- GPS+Galileo on first run, GPS only today

- same atmospheric conditions in all runs I compared. 

- Same route along a river without any trees

Today's run. Off completely, I ran on the path in the park and then along the river.

Here's the bad part from wednesday's run, again running along the river:

and here are both of those parts from last sunday's run, where I had firmware 4.20 on the watch (same settings again):

Unacceptable if you ask me

Parents
  • After I read your comment I checked some of my runs. I do always the same route and I can compare old runs with Firmware 4.20, newer runs with Firmware 5.90 and the latest with 6.20. The route is not that easy than yours because there are lots of trees and the Signal should be worse, but it looks always fine and always the same accuracy, so I have no difference with the GPS on new Firmware.

Reply
  • After I read your comment I checked some of my runs. I do always the same route and I can compare old runs with Firmware 4.20, newer runs with Firmware 5.90 and the latest with 6.20. The route is not that easy than yours because there are lots of trees and the Signal should be worse, but it looks always fine and always the same accuracy, so I have no difference with the GPS on new Firmware.

Children
No Data