100% discharge in less than 12 hours after installing FW 4.1

Did anyone encounter a 100% discharge in less than 12 hours after installing FW 4.1?  I did!  Device updated, rebooted, charged to 100% and the next day (a bit less than 12 hours) in was off.  ZERO battery.  Before that I was using less than 10% battery a day (minimal device functions, no gps, no bluetooth, low screen & vibration, etc.).  I charged it again today to 100% percent and I will see how long that will last.  Anyone?

  • Did your battery drain issue persist after you recharged it? Did it eventually go back to normal? If you are still experiencing high battery drain, can you please perform the following steps:
    1. Plug your watch into a computer with USB.
    2. Open Garmin Express which will put the device into USB mass storage mode. You should see the USB indicator on the Vivosport screen. If you haven't previously used Garmin Express, please install it, then use the "+" button and it should put the device into mass storage.
    3. In Windows Explorer, please navigate to your Vivosport folder. Enter the "GARMIN" folder. Please delete the file called "GarminDevice.xml". Don't worry, this file will regenerate and this will not damage your device.
    4. Unplug the device from the computer and wear again and observe whether or not the battery drain condition is fixed.

    Please report back if this fixes your issue or if you are still experiencing the high battery drain condition.

  • Former Member
    0 Former Member over 2 years ago in reply to Garmin-Brennan

    Hi, I was experiencing the same issue and deleting the "GarminDevice.xml" resolved the battery drain issue.

    Model: Vivosport v 4.2

  • I'm having the same issue but after firmware v 4.2. Tried the method described above of deleting the GarminDevice.xml file from the watch a couple of times to no avail. I'd sincerely appreciate any other suggestions

  • I've had the same issue after updating to 4.2 yesterday. Very much less than impressed Garmin! Have just deleted the .xml file and charging again. Will see how long that lasts. No other suggestions to make at this point.

  • Deleted GarminDevice.xml and now is holding battery fine again! Great!

  • Spoke too soon. Back to discharging very quickly again. Any clues Garmin on a fix or is there going to be another update soon to fix this?

  • Near new Vivosport also has battery drain, used to last a week on one charge and now only 1 day.

    Have just deleted the file and will report back in a week.

  • Same here, have tried all the suggestions below to no avail. It is very frustrating, to say the least! Sometimes I can’t even complete a run before it’s discharged. Any new news or updates or suggestions please? 

  • I am having the same issue, I tried the solution to no avail 

    Fully charged at 10pm last night, now at 5.45am it’s at 70%

    please advise ASAP

  •  If you are experiencing high battery drain, can you please perform the following steps:
    1. Plug your watch into a computer with USB.
    2. Open Garmin Express which will put the device into USB mass storage mode. You will see the USB indicator on the Vivosport screen. If you haven't previously used Garmin Express, please install it, then use the "+" button and it should put the device into mass storage.
    3. On the desktop, please navigate to your Vivosport folder. Enter the "GARMIN" folder. Please delete the file called "GarminDevice.xml". This file will regenerate and this will not damage your device.
    4. Unplug the device from the computer and wear again and observe whether or not the battery drain condition is fixed.

    Please report back if you are still experiencing the high battery drain.