Vivomove style, touch by itself


I have a week old vivomove style, with a little issue.

Most of the times, when i double tap it wakes up, and shows widget. All good;) 

But sometimes after double tap, the watch longpresses by itself, and goes one step further, and goes to the screen activities(not inside activities, but where you can press on activities) 

Anyone tried this before, or maybe have a solution? 

Thank you:) 

  • Mine doesn't do it, however I usually double tap on the side of the case, not on the screen. I tried several times double tapping on the screen after I read your post and it did not longpress by itself in any case.

    Try tapping on the side, if the issue disappears could it be that when you double tap on the screen sometime you inadvertently keep your finger longer on the screen and trigger the long press? 

  • I didn't know that double tap on the case, would wake the screen... Thank you! :) It look like, it's working now. No errors when i'm tapping the case