Watch faces from connect IQ not working


Is anybody having any issues with watch faces downloaded from connect IQ not working since the update last week? was working fine then my watch updated and any downloaded face I have just gives an error icon in the watch face selection screen.

  • Guys, mine is fw 6.60 , and says that there are not fw updates available. Is That OK?

    I tried turning off and on.

    I tried "rebooting" (pressing 15 seconds).


    Any other workaround?

  • I've tried many, many widgets and watchfaces and the behaviour is consistent across all FW versions (I'm now on 7.2): widgets which query a GPS update crash third - party watchfaces. Widgets which either don't use location at all, have user-settable coordinates or use last position, don't cause any problems. It's as far I can tell 100% consistent.

  • i observed that my watch face crashes only when i am active and heart rate goes up. No widgets using GPS and no activity started. Just be very active all day and watch face will crash often during day ;)

  • Sounds like it might be specific to the watch face you're using.  In the app store there is a "Contact Developer" link for each app, and you can use that to let the developer know.

    Also, you want to make sure you're running the latest firmware on the watch as there is a known issue with older FW and apps built recently.

  • I’m having the same watch face problem AND my watch won’t power off. Any other work-arounds people can suggest?

  • As I wrote elsewhere, just see to it that your widgets don't try to query GPS. If possible, either set them to last position or manual coordinates input. Also, having as few watch faces as possible helps. As for the power off issue, try a reboot by pressing and holding the button for at least 15 sec. To power up again press and hold again. Hope this helps somewhat. 

  • Make sure you are running the latest FW on the devices.  There a problem with the app store when it allows installing CIQ apps on devices without the proper firmware.

    If things get stuck, hold the button for about 20 seconds, and the watch should power down on it's own.

  • Bianca of Support told me to hold down the side button for 45+ seconds then let go.  Then power on the device.

  • After many test runs and lots of lost sleep, I've come to the following conclusions:

    1. The crashes are caused by widgets querying GPS data. 

    2. Not only watch faces are affected, also third party apps become unusable. This is a show stopper for me. 

    3. The solution: widgets which have that option in settings should be set to predefined locations, or to last GPS position. In the latter case make sure you have a fresh GPS lock, either by starting an activity which uses GPS or use 'check time with GPS' in the settings - I have it in my quick control menu. 

    4. I think de main culprits in the reported crashes here are the weather widget or the sun/moon widget by Garmin, which can't be set to a predefined position. Just remember to have a fresh GPS lock before you use them and all will be well. 

    5. I've saved myself a lot of money by not having to buy a different Garmin ;)  

    Please try this and let me know your experience.

  • I updated my vivoactive 3 software by using Garmin Express. Download the Express from PC, then update the software on the watch. After that the IQ error goes away and now you can download apps from Garmin IQ!