This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Can't Connect to App


I have the Index Scale and when I try to connect the device in the app, I get to the point where it looks for WiFi, but it never finds any networks at all.  I think I managed to get the device connected to my WiFi with the WPS method (I see the Garmin Scale in my connected device list on the router and I can ping it).  I also see the device now on site under devices.  It show that an update is pending. 

The scale display just shows the Wrench and the bluetooth symbol.  When I connect with the app, it still tries to create a Wifi connection, but it still doesn't find one. 

My router is using only 2.4GHz channel 11 and my SSID is less than 8 characters and the password is more than 8.

Does anyone have any suggestions?

  • So I reset my phone and then was able to complete the setup process, but after it finishes, the Scale just shows the Wrench and a flashing WiFi icon.  I've tried fully removing and rebooting again, but I get the same thing.  Also tried a factory reset.

  • I have exactly the same Problem starts here since i am using an iPhone 14 Pro Max with iOS 16

  • I have exactly the same Problem starts here since i am using an oppo a5s mobile  i know my mobile phone is old but working fine 

  • I could not get the device connected.  I started to think the scale couldn't handle the advanced wireless protocols (my newest router is the X89-X that supports wireless 6+).  I brought up an old, simple wireless ABG router and voila!  It connected properly.  This doesn't really help me as I don't intend to revert to older wireless protocols, but at least I identified the problem.

    The solution was to buy the new version of the scale.