power meter drift issues?

hey all,

unfortunately i've fallen into the power meter accuracy snake pit.

recently i've been seeing what looks to me like power meter drift. you
can see a pretty good example of this from my last trainerroad workout
here (done on a pre-2017 wahoo kickr snap):

https://analyze.dcrainmaker.com/#/public/ade655fb-936b-462b-6037-ef06a2775681

one power meter is a set of garmin vector 3 pedals with a claimed
accuracy of +/- 1.0%. (i've followed the service advisory notes for the
vector and verified the spindle torque. after installing the vectors i
reset the install angles and i also did a static torque test, as
described on the official garmin support pages, using a rice lake
calibrated 20 kg weight). the second power meter is a powertap g3 hub
with a claimed accuracy of +/- 1.5%. both power meters were calibrated
(zero'd) before the workout, which was done indoors at a consistent
temperature of around 70 F.

at the start of the ride, the powertap numbers are a few watts below the
vector numbers, which makes sense given some drivetrain power loss. but
by the end of the ride the power meters have reversed, with the powertap
giving numbers about 10% above the vector numbers, which seems wrong.
(aside from the drift, the difference between the two power values seems
out of spec for claimed accuracy of the devices, especially when you
consider that there should be some drivetrain power losses).

has anyone else seen something like this before? to me it seems like
one of the power meters is drifting out of spec? any ideas what else
might be going on or how to root cause the problem (short of buying
a tacx neo or a third power meter ;)?

cheers,
ed
Parents
  • If the pedals were substantially undertorqued on installation (say, below about 20 N-m or 15 lb-ft) then they may never settle in. They will just (like any pedal) slowly fret out the threads on your cranks, and give you inconsistent power data.

    There is no downside to doing the static weight test at the end of a ride. For Vector it is important that all the parts are at thermal equilibrium when you do the zero offset calibration, and if you've been riding for some time in a static setting then that should certainly be the case.

Reply
  • If the pedals were substantially undertorqued on installation (say, below about 20 N-m or 15 lb-ft) then they may never settle in. They will just (like any pedal) slowly fret out the threads on your cranks, and give you inconsistent power data.

    There is no downside to doing the static weight test at the end of a ride. For Vector it is important that all the parts are at thermal equilibrium when you do the zero offset calibration, and if you've been riding for some time in a static setting then that should certainly be the case.

Children
No Data