Edge 820 Not Keeping Ride Info

My 820 works great throughout ride, shows totals at end, but won’t upload to Garmin Connect or Strava, then ride disappears completely from device after 20 mins or so like it never happened. This is new issue, started after I got new iPhone 11. Premed phone rides still there. Help?

  • This happened to me as well. looking for answer

  • This has not yet happened to me, but when one of my Edge devices starts being wonky, I save my configs and do a factory reset. 

    Non-prompted Non-Vol Clear – (Factory Reset) Clears NV and deletes all FIT files including Activities, Courses, Workouts.

    1. Turn device off
    2. Hold Lap/Reset and Start/Stop
    3. Press and release the power button
    4. Continue to hold only Lap/Reset and Start/Stop
    5. Release Lap/Reset and Start/Stop when the Garmin Logo is cleared
    6. The unit will restart and clear non-vol

    Saving settings for before reset

    Folder Name

    Contains

    Copy  contents of this folder to new unit folder:

     

     

     

    Activities

    Activities

    Activities

    Apps

    Connect IQ apps

    Copy prg files to Apps

    Courses

    Courses

    NewFiles

    HMD

    Screen layouts for HMD

    NewFiles

    Locations

    Saved locations

    NewFiles

    Records

    Personal records

    NewFiles

    Segment_List

    Leader board selection for segments

    NewFiles

    Segments

    Segments

    NewFiles

    Settings

    User profile and sensor pairings

    NewFiles

    Sports

    Screen layouts

    NewFiles

    Summary

    Activity summary from other devices

    NewFiles

    Totals

    Activity totals

    NewFiles

    Workouts

    Workouts

    NewFiles

    Multisport (Watches only)

    Multisport settings

    NewFiles