Ignore sensor? Stop asking me to connect

I have a dual-connectivity HRM (ANT+ and BLE, made by Polar), connected over ANT+ and working well. However the Edge 130 always asks me if I want to pair to the BLE part of the HRM too, and has no option I can see to "never ask me again" so I have to do this at the start of every ride. Is there any way to configure the Edge to stop asking me?

Also, all the pop-ups with "helpful" advice are super annoying – why do they keep popping up again and again even after I've already clearly understood the feature they're advertise?! Is there any way to downgrade the firmware to about 6 months ago when it worked fine and didn't have these annoyances?

  • I can't speak to the ignoring the BLE, but as for the pop-ups (referred to as Spam in other posts), they seem to reoccur with each new firmware version, then settle down a bit.  Truly aggravating, there should be a way to turn off "screen tips" or whatever they call them.  It seems to me as if once you've used the device long enough with the present firmware that the screen-tips messages don't show up every time, just randomly going forward.

  • I have experienced the same with BLE prompts while a device already is connected by ANT+. It's annoying... Workaround: Just add the BLE connection next to the ANT+ and disable it.