Edge 130 Altimeter calibration: Input range only 0-100m

Good afternoon,

From the western part of The Netherlands. I want to calibrate my Edge 130 altimeter in my backyard which is at 1,5m below sea level. However, the input range of the manual calibration of the altimeter is only from 0 to +100m. No other options available, No Auto calibration, No option to match with the GPS height.

Running the latest firmware 3.70. Does anyone have a solution?

Of course starting at 0 instead of -1,5 is no big deal but I wonder how to calibrate on holidays in the mountains for example...

Regards, Folkert

  • Make a waypoint at your starting location, the place where you start your Edge.
    Edit this waypoint with Basecamp or a text editor end make sure it has the right altitude.
    If your Edge is started near this waypoint, it will use this waypoint to calibrate the altitude.

    Attached a waypoint, the lowest point in the Netherlands. The altitude is -6.76 meters.

    <?xml version="1.0" encoding="utf-8"?><gpx creator="Garmin Desktop App" version="1.1" xsi:schemaLocation="http://www.topografix.com/GPX/1/1 http://www.topografix.com/GPX/1/1/gpx.xsd http://www.garmin.com/xmlschemas/WaypointExtension/v1 http://www8.garmin.com/xmlschemas/WaypointExtensionv1.xsd http://www.garmin.com/xmlschemas/TrackPointExtension/v1 http://www.garmin.com/xmlschemas/TrackPointExtensionv1.xsd http://www.garmin.com/xmlschemas/GpxExtensions/v3 http://www8.garmin.com/xmlschemas/GpxExtensionsv3.xsd http://www.garmin.com/xmlschemas/ActivityExtension/v1 http://www8.garmin.com/xmlschemas/ActivityExtensionv1.xsd http://www.garmin.com/xmlschemas/AdventuresExtensions/v1 http://www8.garmin.com/xmlschemas/AdventuresExtensionv1.xsd http://www.garmin.com/xmlschemas/PressureExtension/v1 http://www.garmin.com/xmlschemas/PressureExtensionv1.xsd http://www.garmin.com/xmlschemas/TripExtensions/v1 http://www.garmin.com/xmlschemas/TripExtensionsv1.xsd http://www.garmin.com/xmlschemas/TripMetaDataExtensions/v1 http://www.garmin.com/xmlschemas/TripMetaDataExtensionsv1.xsd http://www.garmin.com/xmlschemas/ViaPointTransportationModeExtensions/v1 http://www.garmin.com/xmlschemas/ViaPointTransportationModeExtensionsv1.xsd http://www.garmin.com/xmlschemas/CreationTimeExtension/v1 http://www.garmin.com/xmlschemas/CreationTimeExtensionsv1.xsd http://www.garmin.com/xmlschemas/AccelerationExtension/v1 http://www.garmin.com/xmlschemas/AccelerationExtensionv1.xsd http://www.garmin.com/xmlschemas/PowerExtension/v1 http://www.garmin.com/xmlschemas/PowerExtensionv1.xsd http://www.garmin.com/xmlschemas/VideoExtension/v1 http://www.garmin.com/xmlschemas/VideoExtensionv1.xsd" xmlns="http://www.topografix.com/GPX/1/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:wptx1="http://www.garmin.com/xmlschemas/WaypointExtension/v1" xmlns:gpxtrx="http://www.garmin.com/xmlschemas/GpxExtensions/v3" xmlns:gpxtpx="http://www.garmin.com/xmlschemas/TrackPointExtension/v1" xmlns:gpxx="http://www.garmin.com/xmlschemas/GpxExtensions/v3" xmlns:trp="http://www.garmin.com/xmlschemas/TripExtensions/v1" xmlns:adv="http://www.garmin.com/xmlschemas/AdventuresExtensions/v1" xmlns:prs="http://www.garmin.com/xmlschemas/PressureExtension/v1" xmlns:tmd="http://www.garmin.com/xmlschemas/TripMetaDataExtensions/v1" xmlns:vptm="http://www.garmin.com/xmlschemas/ViaPointTransportationModeExtensions/v1" xmlns:ctx="http://www.garmin.com/xmlschemas/CreationTimeExtension/v1" xmlns:gpxacc="http://www.garmin.com/xmlschemas/AccelerationExtension/v1" xmlns:gpxpx="http://www.garmin.com/xmlschemas/PowerExtension/v1" xmlns:vidx1="http://www.garmin.com/xmlschemas/VideoExtension/v1">
    
      <metadata>
        <link href="http://www.garmin.com">
          <text>Garmin International</text>
        </link>
        <time>2020-12-28T09:38:33Z</time>
        <bounds maxlat="51.981162428855896" maxlon="4.625437259674072" minlat="51.981162428855896" minlon="4.625437259674072" />
      </metadata>
    
      <wpt lat="51.981162428855896" lon="4.625437259674072">
        <ele>-6.76</ele>
        <time>2020-12-28T09:37:39Z</time>
        <name>Geodetic Point1</name>
        <sym>Waypoint</sym>
        <type>user</type>
        <extensions>
          <gpxx:WaypointExtension>
            <gpxx:DisplayMode>SymbolAndName</gpxx:DisplayMode>
          </gpxx:WaypointExtension>
          <wptx1:WaypointExtension>
            <wptx1:DisplayMode>SymbolAndName</wptx1:DisplayMode>
          </wptx1:WaypointExtension>
          <ctx:CreationTimeExtension>
            <ctx:CreationTime>2020-12-28T09:37:39Z</ctx:CreationTime>
          </ctx:CreationTimeExtension>
        </extensions>
      </wpt>
    
    </gpx>

  •  Can you give me some practical help with this? Started a ride at home, marked the home location which is now in the list with an altitude of 2 meters. How to find this waypoint on the Edge when connected as USB drive?

    BTW, I can edit the altitude of this waypoint in my Edge 130 but again from 0-100 meter only. Since my altitude on the ground is -1,65 I can set it to 0 when holding the Edge at 1,65 m above the ground of course.

    Also tried to find the waypoint in BaseCamp but I can only find Routes and Rides and 1 waypoint from Garmin HQ in the US.

  • Unfortunately it doesn't work. Yesterday I started at a waypoint @0m and all was fine. Today I started at the same waypoint while air pressure dropped 2 hPa due to weather conditions and I started at 12m above sea level so it looks like the waypoint is ignored. The total ascent value at the end of the ride is correct.

    Anyway, thanks for your help.

  • The waypoint should not be ignored.
    But you need to make sure that the waypoint matches the exact starting location where you would normally start your Edge.
    Then you should start your Edge at that location and do not move it until it says "GPS ready" or "GPS location determined".
    If you are more than xx meters away, the waypoint will not be used.
    In some places this can be a problem, between buildings, interference from electrical appliances, etc.

    It works for me when I start the Edge near my house (where I made the waypoint).
    If I start it at the end of my (long) driveway at the gate, it sometimes doesn't work.

  • Switched on the device at max 1 meter from the waypoint, waited for GPS and started the ride, all at the same spot  max 1 meter from the waypoint. No surrounding high buildings, clear sky view, GPS+Galileo active.

    I will give it another try at a fixed spot in my garden...

  • The data in the waypoint must be accurate.
    Location and height.
    This could be difficult if you first used the Edge to make the waypoint, because it doubles the possible error. try to make the waypoint in Basecamp, or edit it manualy and reload it to your Edge.

    I tried to manually calibrate the altimeter.
    It ranges from 0 to 100099m (V3.70).
    Don't think you'll run into problems on your bike hollidays.

    I use GPS and Galileo too.

  • Ah you are right, it's up to 100099 m indeed. Strange that you can't go negative though. I could not manage to put a waypoint in it with Basecamp. This piece of software looks outdated from the Windows XP era. Anyway, I will give it another try this week from a fixed point in my garden and I'll let you know.

    Edit: Cleared all waypoints, made a new one on a fixed location in my backyard yesterday while air pressure was 1023,5 hPa (official weather station) and set it to 0m. This morning I started exactly at the same spot with an air pressure of 1018,3 hPa, waited for 5 GPS bars, pressed "Ride" until GPS Ready appeared and started to ride. The ride started at 0m so it looks like it's working! For now I will start rides at different locations, with and without a waypoint close by as air pressure is expected to drop today and tomorrow so it will be the ultimate test. To be continued...

  • It is! This morning I switched on the device at the same spot again while air pressure dropped several hPa over night. Pressed the start button and waited for "GPS is ready". Height showed +73m! (as expected after nightly air pressure drop) However, when I really started the ride (timer running) the height jumped to 0m immediately!

    So the important message is that correction takes place when you actively start riding, not during device startup.

  • Good work.
    I never noticed this, never checked before starting, only afterwards...