Firmware 9.0 still can't connect to iPhone 11 Pro

Before my ride yesterday I updated to 9.0. I was so happy the bug connecting to iPhone 11's was fixed. It got through the pairing successfully and the Connect app got to the part where it said the connection was complete. However, then it just hung on that screen. The 1030 still thought it was trying to complete the connection. I restarted the app and it said that it didn't complete the connection process successfully and so I tried again many times. Same thing every time. I've removed all Bluetooth connections and tried many times but can't get it to complete the connection. So I eventually gave up in frustration and went on my ride. I was surprised that I got a notification on the 1030's screen for a text I received. So I looked at it and the Bluetooth does appear to be successfully paired, it's just that the Connect app can't finish it's connection process. The 1030 does say it's connected to my phone, but the app doesn't.

I'm using an iPhone 11 Pro with iOS 13.2 and Garmin Connect 4.24.1.4.

Any ideas how to fix this? Is anyone else having this issue?

Thanks.

Parents Reply Children
No Data