HR not working on 8.70 and 9.02

Hey everybody. I've had my instinct for a little over a month now and have been loving it until today. It died this morning, I plugged it in to charge and when the battery was full I put it on my wrist but I never got the HR back. It's been on 8.70 for maybe 3-4 days now and HR was working properl, even last night before it died as I get the sleep data. For HR it now says "measuring" but no green lights are flashing at all. Also, when I broadcast my HR, it gives me some numbers but there are no green lights. I tried turning HR on and off, restarted the watch couple times, updated to 9.02 beta but still the same. I would really not want to restore it to original settings....

Thanks in advance!

  • so I restored it to original settings, installed 7.20, 8.70, 9.02 beta, tried everything and still the green LEDs will not flash. Under settings/about the WHR says 20.03.32. Seems like it's measuring my pulse during activity (but doesn't flash green still), but no measurments during non-activity