Headphone disconnects after starting activity


Since 10.10 FW I've a weird issue with my previously flawlessly working headphone (Jaybird Vista).

When I go running usally I start listening Spotify before leaving my apartment, then I go downstairs and start running activity in the street. After a few minutes of running my headphone says "Not connected" and the watch shows me a PLAY button instead of PAUSE, so the playback has been paused and the headphone has been disconnected. When I press play and choose Jaybird Vista, it connects and starts to play, but disconnects after another few minutes, and so on....

If I pause my activity and restart the watch then continue my activity and start Spotify again it works till the end without and disconnect or dropout... however the language of the voice prompts are changing from hungarian to english.

If I keep my headphones off when I start running, and only start listening to music after started the activity the connection is fine and I've zero disconnects during the workout, however the language still changes from hungarian to english.

What I've tried:

  • repairing my headphones
  • tried the headphones with smartphone, no dropouts or disconnect for hours
  • change the default voice language from hungarian to english
  • made a full factory reset with secondary master reset and even Garmin Connect reinstalled and repaired
  • installed 10.75 beta

Current software:

  • Fenix 6X Sapphire
  • FW 10.75
  • GPS: 4.50
  • Wi-Fi: 2.60
  • CIQ: 3.2.0
  • BMX: 0.9.2
  • WHR: 0.09.02
  • ANT/BLE/BT: 6.06
  • Sensor HUB: 7.12

None of these solved the problem, so now I'm a bit clouless.
Everything was working fine with 9.XX firmware, so it must be something software releated, but I'm out of ideas.

Thanks for your answers!

  • This may not be the same issue but I've noticed that if my bluetooth headphones are connected to additional devices, such as my phone, along with my watch it starts acting weird and disconnecting from the watch once I am out running and get out of range of the other device. I had that happen and had to restart the watch to fix it.

    What I've found works is making sure that I disconnect other bluetooth devices from the headphones before I leave so that the watch is the only device connected. This doesn't mean they have to be unparied, just disconnected. Like I said this might not be the same issue but if you do have your headphones connected to multiple devices give this a try. No idea about the language issue since I don't use the voice prompts and would have it set to English anyway but hopefully fixing the disconnect issue will solve that problem for you as well.

  • The same thing is happening to me...but only with my Jabra 65T Active. If I do use my AirPods Pro or my Zolo Liberty everything is working as usual. 
    Today I was getting mad: started Spotify.....then started running activity and after a minute the headphone disconnected themselves. I pressed Play on music controls, I selected Jabra 65T...my watch connected to the headphones, started playing for few seconds and then the headphones disconnected themselves again. And so on...

    The only way to be able to listen to music is not to have an activity running foreground or background. 

    Tonite I Made other tests: with my Jabra connected even waiting into activities list waiting to select an activity made my Jabra disconnect after about 40 seconds... Disappointed

  • Just to be crystal clear: my Jabra as well al other headphones I tested were connected to the watch only

  • This is an issue with the Jabra's being both headphones AND a footpod.

    Delete your current pairing.

    Then pair them again AS A HEADPHONE only. Do NOT pair them as a footpod, or Search All Sensors.

    Thanks for your detailed answer, sadly my headphone only connects to the watch. Something must be with the 10.XX firmware, but I can't figure it out. 

     Yesterday I've tried again and if I start the activty first (outdoor running) then after a few seconds later I switch on headphones and start music/podcast I got zero disconnects or dropouts during a 90 min run. Could you try this with your Jabra?

    Another interesting thing what I've found on my past runs: Where I've paused the activity and restarted the watch to resolve this headphone disconnecting issue, the watch connected to the external sensors (Stryd ANT+, Garmin HRM Run ANT+), but the data is completly useless:

    This is a 5K run where I've started music after the activity and the sensors working flawless (at 15:50 I've paused becaused):

    This is a 15K run same day, where I had to restart the watch after 1K to solve the headphone disconnect issue and even Stryd and HRM Run has reconnected, the data is a complete mess:

    Dear , do you have any ideas?

  • That's really interesting: I've owned these headphones since last year and I didn't even know that they could work as a footpod too. On the Italian jabra site it's not even mentioned this feature! :/

    Anyway, yesterday I unpaired and paired these headphones many times but nothing changed. And, I did pair them from music menu -> headphones.

    But thinking about that they are even footpod, few minutes ago I tried going into All sensors menu....and guess what? I found two rows about Jabra Elite Active 65T, one as a footpad and one as headphones!!!!

    As I wrote, I paired these headphone ONLY from music->headphones menu!! But even this way the watch paired them both as a pair of headphones and as a footpod!!!

    Anyway, I just removed the footpod association and everything continued working as usual!!!

    Thanks for the hint!

  • I run with Polar OH1, Stryd and Jaybird Vista's and have experienced the exact same issue since upgrading to v10.x.

    Here is the solution:

    Roll back to ANT/BLE/BT v5.04

    After doing this, my Jaybird Vistas are working flawlessly once again.

    I have also reported this to Garmin and have yet to receive a response.... should I hold my breath.... probably not.  But it would obviously make a case if you also reported it.

    I have also noticed the connection to my phone is much more stable since downgrading, so in my opinion I think there is a problem with v6.06.


  • This sounds promissing . I'll go run on the next two hours. Could you give me a download link for the ANT/BLE/BT v5.04 file to give it a try?

  • I keep all versions of software released, just so I can roll back to a working version if I have to.  I did a bit of digging and you can find ANT/BLE/BT v5.04 here:  https://forums.garmin.com/outdoor-recreation/outdoor-recreation/f/fenix-6-series/231094/fenix-6-series---9-98-beta-release

    Let us know your results, but after 2 x hour long runs, I have not had a single disconnection issue.  (No matter what order I turned on devices).


  • I've also found this topic (and 9.0 RC), but the download link has been updated to 10.77 on the beta page.
    Sadly previously working Garmin firmware archive is also down. :(

    Could you please upload 9.98 beta in a ZIP file somewhere?