Fenix 6s Sapphire gesture backlight gesture sporadic


Recently got a Fenix 6s Sapphire. Love the watch, truly, it's an amazing piece of kit. 

That said, when I first got it I turned on the gesture for the backlight, and it worked great. I then did all of the updates to maps and to software, which put the watch at 5.0. Gesture still worked fine (been about 24 hours of it working fine after the update). Then last night after work, I noticed that the gesture had stopped working. (this is gesture NOT during activity)

This morning it was still not working. I turned gesture off and then back on, still not working. Then just before I went to write this (about 20 minutes after I had turned gesture off/on), as if the watch somehow knew I was going to, the gesture miraculously started working again. But I had done nothing further.

This is not some kind of emergency, and not a deal-breaker for me on the watch. That said, when you spend $800 on a watch (maybe that's not a lot for some but for me it's a LOT), you kind of expect it to just work.

So I thought to let you know that there might be a slight issue with gestures; not sure if others have had this issue... I didn't find anything specific to my problem in forums but I didn't do an exhaustive search. 

Thanks for your time.