Vibration too short - Fenix 5

Any way to adjust the vibration time for incoming calls?  Mine vibrates twice quickly, and if active I don't usually feel it.   I have set the 'timeout' under the 'phone' settings to 30 seconds and 1 minute but that does nothing, not sure what that timeout function controls.

Great watch but this is annoying.

  • I'll add a 'me too' to this one. I gave up on adjusting it quite some time ago but I notice that I miss these vibration alerts quite frequently.

    On the other hand, some apps (notably outlook calendar) can be set to send multiple notifications and I've found that to be helpful (and sometimes downright annoying because they keep on coming even after I've noticed them...)

    It'd be nice if calls could be set to notify more than once?

  • Same for me. I had a Fenix 5S plus a few weeks ago and I felt the vibrations when receiving calls much better.
    With the 5 I have missed a few calls and only noticed the "missed call" notification.
    It would be nice if we could set the vibration level...

  • I have set the 'timeout' under the 'phone' settings to 30 seconds and 1 minute but that does nothing, not sure what that timeout function controls.

    This controls how long the info is displayed on the watch. 

  • Same issue here, a few weeks ago my watch used to vibrate all along while someone was calling 

    Now it only vibrates once or twice, this looks somehow upgrade related.