Major Altimeter-Barometer-Temperature Malfunction

Over the past several years, I have had a series of Forerunners (910XT, 920XT) and Fenixes (2, 3, 3HR, 5x) which have all developed total malfunction of altimeter-barometer-temperature. I seem to have been one of the few until the 3HR, on which many had similar problems. Just the other day I was thinking to myself that maybe this would not happen with the 5x, until mid-morning yesterday when suddenly while at work, the problem developed on my 5x. The clue is that the altitude suddenly went to approximately -65,000 feet. The barometric pressure showed no change. The temperature read 451 degrees. I tried recalibrating the altimeter, at which point the barometric pressure became bizarre and incompatible with life. So, I updated to the new beta firmware (4.21) with no change in these reading. I then soaked in soapy water (on the theory that the sensor port may be clogged; this has never worked for me). Then I did a hard reset. Following the hard reset, here are the numbers: altitude -68337, barometer 1013.2, temperature 561.

I realize that I may be the only person who has had this problem with every one of the devices. I wonder if there is something in the pool I use (salt water pool at Lifetime fitness) that degrades the sensors. I take impeccable care of the watch and rinse the sensor port under running fresh water after every workout. I'd rather not have these features on my watch than have these bizarrely wrong values and am not sure what to do at this point. I will call Garmin Monday and they will probably replace the device (hopefully). I love the functionality of the 5x and there is nothing out there that compares but I hate going through this repeatedly and am seriously considering switching platforms, though nothing out there appeals to the same degree.

I welcome suggestions.
Parents Reply Children