Fenix 5 Plus does not sees any Wifi networks

I have ongoing problem with my Fenix 5 Plus (firmware 6.0)- it does not sees any WiFi networks. It was working in the past, and primary use for me was to synchronize Spotify playlists.
Strangely - it does not connect to earlier defined network anyway. What is more - it does not sees ANY network - no matter if the search is done via watch itself or via Connect app (on Android). I tried many times in many places - so my home network, on on public networks, etc.
What is more, just today I have replaced my home Access Points, and I have set up entirely new WiFi network at home. It works perfectly fine with all home devices - but F5+ simply does not sees it.
The activities synchronizing works fine over Bluetooth, but my Spotify playlists have expired - so I cannot use them anymore.
Have anyone experienced such problem? Any advice's?
  • Just tried this fix and it worked perfectly for my Fenix 5x plus. Switched the channel from auto to one below 11 and boom. It connected immediately. 

  • Did you find solution. I have same problem with wifi.

  • All attempts to solve it by configuration or software updates failed. Watch was eventually replaced by Garmin. 

  • Just got a Fenix 5 Plus and out of the box it wasn't finding any networks at all. However just updated firmware (to v13) on the watch and now all is working and the WIFI networks are being found

  • The Fenix 5 plus had severe Wifi issues when it was launched. The problems were solved with several updates over the years.
    I could not connect with my Vodafone Cable router, but since last week even that works. As this was the only router, which did not work with the F5+ (and with my sons Venue), it was very likely an issue of the router and I assume that an update of the router solved it, as there was no update of the watch. 

    In general the Garmin watches (and most other smartwatches) do not connect to 5GHz Wifi! Maybe this is helpful for those who still have issues.

  • Mine was working great until the update to 13 and now it won't connect. Sometimes it finds the networks but then crashes upon any attempt to login and requires a hard reset. Doesn't matter if the network is added via the watch or via the app.

  • That's strange. The only idea I could provide, is to remove the connections, do a soft reset (switch off and on again), connect to your computer and setup the connections in Garmin Express. Maybe that helps.

  • Recognizing this started 2 years ago with updates as recent as 6 months I offer this possible solution. My watch lost networks after a software upgrade. Various messages of "no networks"

    Without all the details which I have posted in similar thread, the simple two step process for me were to:

    Using the WATCH, delete the networks (specific steps covered in manual) (menu>settings>networks>yadah>yadah)

    Using smart phone Connect app (not IQ) add the networks back (of course with passwords) :-)

    Smartwatch,being dumb, searches again for the networks, finds them and connects

    There can be issues if your wireless router was upgraded from 2Gs to 5Gs, this method above also solved that for me. Verizon went from 2.4 or 5 to 5G.

    This has not been an issue of encryption WEP, WPA2 (AES or TICK) or WPA3. Advanced Encryption Standard (AES), older Temporal Key Integrity Protocol (TKIP) or first Wired Equivalent Privacy . Fenix 5 works fine on WPA2 and WPA3 in my case.

    Not trying to turn this thread into an encryption thread, nor a router thread, just identifying possible "but what if I have XYZ?" These XYZ did not impact making my smartwatch dumb again, and forcing it to relearn the WiFi networks. It did it in short order :-)