Device not charging

Dear Gamin community,

I just stumbled upon the following issue. I was using my watch as normal and after normal use and discharge the watch turned off, when I go home to put it back to charge the device seems completely dead. No screen loading when plugged, no battery charging indication, no response when pressing any of the buttons just completely dead.

I had tried the following actions to no avail:

- Cleaned the connectors on the device and charging dock using rubbing alcohol and a cotton swab.

- Tried different charging sources (computer, wall socket, portable charger).

- Used a different cable.

I had followed Garmin recommended steps on the following video:

Also found this thread (bellow) on the Fenix 5X and tried the suggestions proposed in it and nothing:

Any suggestions from anyone who might had experienced this in the past?

I had already sent an email to Garmin and received confirmation of email but still haven't received a case number.

Cheers everyone!