Not only that, but I don’t seem to have a way to even allow this. When I go to my iOS settings there’s no contacts option for Connect....