Announcement

Collapse
No announcement yet.

GPS not updating have SW update to 11.0

Collapse
X
  • Time
  • Show
Clear All
new posts

  • #16
    I suspect that something .. ON .. my watch is causing garmin express and the webupdater for correcly doing their job. I've never used the beta stream, only official. But clearly, when both methods of updating are failing, the device is likely the key. I do get most updates over the air via GC mobile, but it didnt do the GPS update.

    I'm still waiting on Garmin tech support to chime in, on a ticket I created.

    Comment


    • #17
      I have checked half an hour ago after getting the 11.00 sw update OTA, and yep there was GPS version 4.40!. However, wiring the clock to the PC and synching with Garmin Express rendered what apparently was a second firmware update PLUS a GPS update and now it's displaying GPS version 2.30, no additional marks.

      Comment


      • #18
        I might as well post a "me too!" here. At least it finally worked, but a long way from automatically.

        I got the automatic update to Fenix 11.0 yesterday but the GPS version was left at 4.40(!)
        No amount of connecting using Mobile or PC GC appeared to do anything, even after reboots of the watch. The watch was plugged in via USB when using PC GC and wirelessly when using Mobile GC

        So I found the Garmin Express PC app (not that old, maybe 6 months?) and started it up with the watch connected via USB. It took a couple of tries to find the Fenix and said that it was all up to date except map updates that I didn't even try.
        Disconnected, rebooted watch, no sign of any GPS updates. Sighed and gently banged my head on the desk a few times.

        On the chance that I needed a new Garmin Express, I clicked on 'check for Express updates' and found that there was one. So I updated Garmin Express and reconnected the watch via USB and restarted Garmin Express. It said everything was hunky-dory and up to date except those pesky maps.

        Disconnected the watch, and because a nice reboot never did anyone any harm, rebooted it.
        A 1 minute update of something was available. Promising! Did that and then (maybe after a reboot, I forget, there have been so many...) checked via settings->about->down-button a couple'a times to get GPS version....

        It did finally update my GPS to 2.30. Yay!

        Amazing amount of pfaffing around and trepidation for a so-called automatic update. I have a lot of sympathy for the people who have to try to support it.
        Thanks to you all for helping me retain a shred of sanity. Without your posts I doubt if I'd have tried Express. Haven't ever had to use it with the Fenix before.

        Terry

        Comment


        • #19
          If you have Settings>System>Software>Auto Update>On enabled on the watch, Garmin Express typically (but not always) deliveres new software to the watch as soon as you plug it in and without even telling/asking you. So often you can think nothing has happened, but actually it has and you just need to manually start the software install in Settings>System>Software once the watch is disconnected from PC/Mac. I noticed this behaviour of Express crept in some time ago (in the hayday of the Fenix 3, Express always told you it was about to install software). So it is inconsistent and possibly confusing behaviour; but as folks are finding, persistence pays off in the end.

          Comment


          • #20
            Originally posted by jetguat View Post
            Ok. I expected the GPS version to update on to v2.30 when I updated to SW v11.00
            but it did not. On the software about screen, in fact it says GPS 4.40! (yes it shows the ! as well)

            so how are we supposed to get that GPS version?

            I'm trying to connect to garmin express, but my PC + Garmin Express + 5x do not seem to want to play nicely.
            Thanks for the support
            I have connected my Fenix 5X to Garmin Express and have the same issue. Besides that it sounds a bit strange to "update" to a lower version...

            Correction: I have also again synced and I am getting the GPS update now. Very confusing all of this
            Last edited by Nolip; 10-11-2018, 10:20 AM.

            Comment


            • #21
              I just had same issues. What I found … V.11 was shown when plugged into GE and installed once unplugged though no sign of GPS being updated. Plugged in again hoping it would signal an additional update and nothing showing. Unplugged the Fenix and then the screen showed the GPS update and Fenix updated. Verified GPS v. 2.30 is installed and all GPS options in activities.

              Comment


              • #22
                I am upgraded to 11.0 from beta 10.55, and everything is done automatically. I still have GPS v. 2.30....

                Comment


                • #23
                  I's having this same issue...no luck
                  Tried WebUpdater, and it finds that i need gps update, but it fails to do that.
                  Last edited by Anis82; 10-16-2018, 01:28 AM.

                  Comment


                  • #24
                    Anis82, I can only suggest (if you haven't already, and maybe even then) that you try connecting your watch to a PC and running Garmin Express, maybe more than once, and with a recently updated version of GE. This seems to be one of those s/w issues that can be solved by persistence, as if you have to prove that you really, really want it before the 'system' will relent and do the update.

                    Comment

                    Working...
                    X