Announcement

Collapse
No announcement yet.

Major Altimeter-Barometer-Temperature Malfunction

Collapse
X
  • Time
  • Show
Clear All
new posts

  • #16
    That's the hole that I faithfully and thoroughly rinse after every workout. There is nothing visible there. I suppose it is possible that salt has accumulated on the sensor despite my thorough rinsing after very workout. I'm now soaking the watch in soapy water. In the past that has never worked but I always try that. I read somewhere that vinegar can help dissolve salt and I might try that as well. This is all theory right now since despite having replaced so many units, Garmin has never circled back to me to tell me what they have found in the units I have returned.

    Comment


    • #17
      wborstein

      This may seem a stupid thing to suggest, but is there any chance that rinsing out the sensor aperture is what is causing the problem. I personally would never wash out such an aperture with soapy water due to the possibility of residues etc

      Soap residues are likely to attract dust and dirt which may be difficult to shift.

      You seem to be saying that there are few if any who have this issue recurring on a number of devices. IS it possible that few if any people rinse out the sensor.

      Please note I don't even have a 5X and am reading posts to get an idea of potential issues as I intend to buy one this week.

      I have a feeling that using vinegar on the watch might well invalidate the warranty, vinegar being acidic.

      Is rinsing the aperture a maintenance activity suggested by Garmin?

      This may be a stupid suggestion but it is made in good faith. I hope the issue is quickly resolved.

      Brian

      Comment


      • #18


        Thanks for the suggestions. Just to be clear about this, I do not routinely clean with soapy water; that's just something I try when this happens as a terminal event. There are a few posts around of individuals with this problem who have done the soapy soak and gotten resolution, but as I said that's not been my experience. Rinsing is recommended by Garmin and it's something I started doing after several previous devices developed this problem. That said, your theory is as good as any. I have settled on the theory that it's the pool I use. It's the pool I've used for the past 5 + years and it's a salt water pool and I as I said I use it faithfully year round. Who knows, though. I do share your concerns about the vinegar. I would only use it diluted and would rinse thoroughly afterwards. It's a matter of desperation at this point as I would love for this to be something I can resolve without having to replace the unit every several months.
        Last edited by SUSSAMB; 02-19-2018, 01:54 PM. Reason: Please don't quote the post directly above yours. It's unnecessary and simply clutters up the thread. Thanks

        Comment


        • #19
          Originally posted by wbornstein View Post
          Less than four months have elapsed and the problem has now occurred on my replacement unit. Suddenly yesterday, the altitude froze at 820 feet (unvarying), the barometer froze at 8069.8, and the temperature "froze" at 575 degrees. As I described at the beginning of this thread, this must be my 10th plus occurrence of this problem on virtually every Garmin model with these functions in the Forerunner and Fenix series. Something that I (and others) do is eating up these sensors despite, at least in my case, extreme care with thoroughly rinsing the port after each workout. The only thing I have been able to think of is the saltwater pool I swim in faithfully three times weekly, year round. As much as I love the ecosystem and particularly the fenix 5X, and despite Garmin so far being very good about replacing these units, I'm seriously thinking about finally making the switch to Suunto or maybe even Apple.
          Could it be a body chemistry thing? I know for instance, that when I wear silver, it will turn black, while my mother will 'clean up' silver by just wearing it. Maybe something like that is happening with the exposed parts of the temperature sensor?

          Comment


          • #20


            Interesting thought. I suppose one way to find out is to not use the next one in the pool that I swim in. That defeats the purpose and is a step too far for me. I would love for Garmin to weigh in on this issue but I have never been able to get them to do that.
            Last edited by SUSSAMB; 02-19-2018, 01:53 PM. Reason: Please don't quote the post directly above yours. It's unnecessary and simply clutters up the thread. Thanks

            Comment


            • #21
              Mine just went as well. I had a fenix 3 and returned it after a few weeks because of this issue. Just bought a 5 hoping that this was resolved, and it looks like the situation is no better. Both worked great for about 2 weeks and then altitude and barometer just started going crazy. It may be coincidence, but mine seem to go crazy about a day after being outside in snowy weather.

              I'm convinced all of these are defective and some people just haven't triggered it yet.

              Comment


              • #22
                Not all are defective... with bike-spinning-hydrobike-pool swim and aquagym, if you add the showers and spa mine is a combat F5X. I did have the malfunction and RMAed after 6 months. This is the second F5X then, brand new, 3 months and it's doing ok. The instrument is not necessarily defective and since it's exposed to the outer environment for obvious reasons, it is prone to suffer from the hardship of training types of all kinds.
                At the beginning, the lines of production are not yet tuned to solve manufacturing problems... waves subsequent to the initial release are more and more sturdy luckily.

                I never had this problem with the F3 but I did have it with 3 FR910XT in a row (20 days in ... then RMA... 3 times in a row so I sold the 4th for scrap value).
                F5X - SN# 54H007158 - SDM4, GSC10t, Tempe, HRM Swim, HRM Tri
                Fenix5x Manual

                Comment


                • #23
                  I just got a new replacement Fenix 5X for another unrelated issue and my new device has a faulty altimeter. Crazy thing is that I recently bought a vivoactive 3 and it's also experiencing similar issues. I feel like I'm experiencing the Fenix 3HR altimeter issue all over again in 2 different devices.
                  Fenix 5X; FR 735XT; Edge 820
                  Stryd; Running Dynamics Pod; HRM-RUN; Tempe
                  Garmin Speed+Cadence bike sensors
                  Virb Ultra 30

                  Comment


                  • #24
                    Same with me. My 4 month old 5x had a total failure of A-B-T. Just sent it back yesterday. I also had a failure of my 920xt earlier in the year. I guess I might be one of those unlucky people

                    Comment


                    • #25
                      I've just upgrade from a 3 HR to a 5. After 5 days the barometer is reading 4354.6mbar and my wrist is -51 degree C !!!

                      Comment


                      • #26
                        Over in the 5/5S forums its pretty easy to see that static electricity is causing our altimeter to go crazy. Lots and lots of issues.

                        https://forums.garmin.com/forum/on-t...x-5-5s/155092-

                        Comment


                        • #27


                          As I've pointed out before, I think that there are multiple (or at least two) versions of the ABT problems. The one I have now had on multiple Forerunner and fenix units does not seem to be static related. I'm now on my third fenix 5X. All was fine until this morning when about three hours after a swim, the usual constellation occurred. The temperature, barometric pressure, and altitude all steadily went to values incompatible with life, while I watched. They are now frozen at the following values: altitude minus (-) 12132 feet; temperature 566 degrees Fahrenheit, barometer 5057.3. I've been trying to call Garmin....
                          Last edited by SUSSAMB; 02-19-2018, 01:53 PM. Reason: Please don't quote the post directly above yours. It's unnecessary and simply clutters up the thread. Thanks

                          Comment


                          • #28
                            My Fenix 5 doee the same thing sometimes . I will soon be on my 4th Fenix 5

                            Comment


                            • #29
                              Just off the phone with Garmin support. They will send a new, not refurbished, Fenix 5S overnight. This is my second (or is it third?) replacement for the Fenix 5S for altimeter issues. This time it was altimeter and temperature. Despite GPS and manual altimeter recalibration, my altimeter would read 65000+ shortly thereafter and my recorded rides would read 0 ft elevation or something equally inaccurate. The temperature has been reading 111-113 degrees (btw first support guy I talked to a few days prior tried to tell me this is just a reading that takes into account sunlight, ambient air, body heat, etc. Uh Nope). Support mentioned that watches manufactured around the same time (serial number) as mine had the highest number of similar issues. S/N 566039576

                              Comment


                              • #30
                                Originally posted by wbornstein View Post
                                Over the past several years, I have had a series of Forerunners (910XT, 920XT) and Fenixes (2, 3, 3HR, 5x) which have all developed total malfunction of altimeter-barometer-temperature. I seem to have been one of the few until the 3HR, on which many had similar problems. Just the other day I was thinking to myself that maybe this would not happen with the 5x, until mid-morning yesterday when suddenly while at work, the problem developed on my 5x. The clue is that the altitude suddenly went to approximately -65,000 feet. The barometric pressure showed no change. The temperature read 451 degrees. I tried recalibrating the altimeter, at which point the barometric pressure became bizarre and incompatible with life. So, I updated to the new beta firmware (4.21) with no change in these reading. I then soaked in soapy water (on the theory that the sensor port may be clogged; this has never worked for me). Then I did a hard reset. Following the hard reset, here are the numbers: altitude -68337, barometer 1013.2, temperature 561.

                                I realize that I may be the only person who has had this problem with every one of the devices. I wonder if there is something in the pool I use (salt water pool at Lifetime fitness) that degrades the sensors. I take impeccable care of the watch and rinse the sensor port under running fresh water after every workout. I'd rather not have these features on my watch than have these bizarrely wrong values and am not sure what to do at this point. I will call Garmin Monday and they will probably replace the device (hopefully). I love the functionality of the 5x and there is nothing out there that compares but I hate going through this repeatedly and am seriously considering switching platforms, though nothing out there appeals to the same degree.

                                I welcome suggestions.

                                I have had the exact same issues for the past 2 years. I have worked through approximately 5 watches .. in the Fenix range. My first being Fenix 3. Then I soon moved to the Fenix 5 range but all have failed on the Temp/ Barometer and Altitude sensor. For all watches to fail is crazy and my newest Fenix 5s plus was purchased on 31st August.. Sensor seems to have failed on the 13th October. I Swim five days a week . I pray it is not the pool water. My pool water has no salt. I am now wondering if it is shampoo / washing products that is causing failure. A possible certain ingredient in some washing products?. I wear my watch 24/7 and only remove for charging . I have replacement watch being sent to me tomorrow . The only other product I have used when wearing my watch is a descaling spray in my shower enclosure .. and I de-scale every two weeks normally when I shower on Saturday mornings straight after a run. . so .. maybe this product kills the sensor.. I will have to try some process of elimination. If the watch is failing simply from pool water, then it is not fit for purpose and Garmin will seriously need to sort this out. My sensors are failing within a few months so I seem to be forever returning the watch for new, but losing or my personal records etc in the process.

                                Comment

                                Working...
                                X