Announcement

Collapse
No announcement yet.

Anyone else's weather widget always "waiting for data"??

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Anyone else's weather widget always "waiting for data"??

    So for a while my weather widget was doing great. Almost every time I called on it, it was there. A couple days ago I plugged my Fenix3HR in and set up garmin express.....and since then my weather widget says "waiting for data" almost 100% of the time.


    Now, getting a quick GPS lock fixes the issue for a while, but then it goes right back to waiting for data.


    Is anyone else seeing this? Is there a permanent fix? I *love* the weather feature of this watch so I'm bummed it isn't working most of the time.

  • #2
    All good here. Is it is more likely your phone that may be the problem.
    --
    Fēnix 5X | Fēnix 3 | HRM-Run | Run Dynamics Pod| Stryd 2 |Tempe| Oregon 600 |
    The more I see, the less I know for sure.

    Comment


    • #3
      Originally posted by WillCW View Post
      All good here. Is it is more likely your phone that may be the problem.
      I learned recently that the phone doesn't have anything to do with the weather widget, on a call with Garmin.


      They said getting weather data is dependent on the GPS's last location rather than location services from the phone.

      Comment


      • #4
        Originally posted by ATLinfidel View Post
        I learned recently that the phone doesn't have anything to do with the weather widget, on a call with Garmin.


        They said getting weather data is dependent on the GPS's last location rather than location services from the phone.
        Hm! So you don't need a phone? I don't think so. You still need connection and that could be a phone BT problem. Of course it could equally be an F3 BT or GPS problem.
        --
        Fēnix 5X | Fēnix 3 | HRM-Run | Run Dynamics Pod| Stryd 2 |Tempe| Oregon 600 |
        The more I see, the less I know for sure.

        Comment


        • #5
          Originally posted by ATLinfidel View Post
          So for a while my weather widget was doing great. Almost every time I called on it, it was there. A couple days ago I plugged my Fenix3HR in and set up garmin express.....and since then my weather widget says "waiting for data" almost 100% of the time.


          Now, getting a quick GPS lock fixes the issue for a while, but then it goes right back to waiting for data.


          Is anyone else seeing this? Is there a permanent fix? I *love* the weather feature of this watch so I'm bummed it isn't working most of the time.
          Same issue here

          Comment


          • #6
            Originally posted by WillCW View Post
            Hm! So you don't need a phone? I don't think so. You still need connection and that could be a phone BT problem. Of course it could equally be an F3 BT or GPS problem.
            I'm not totally sure, I'm just relaying what they told me. They said the data comes from the GPS info, which is why opening an app like "run" and acquiring a gps lock makes the weather widget work (even if momentarily).


            I'll call them back when I can and try to elucidate, because I'd like to know. It's annoying that it was working so well and now isn't.

            Comment


            • #7
              Originally posted by Benay148 View Post
              Same issue here


              Open up the run app and let the watch acquire GPS lock. It's at least a temporary work around. A minute or two after GPS lock the widget will work again, at least for a little while.

              Comment


              • #8
                Opening maps on my iPhone and letting it find my location then syncing with garmin connect over Bluetooth usually does the trick for me.

                VPTBOA

                Comment


                • #9
                  BT Connection

                  For me, I need to have a BT connection to my phone for the weather widget to show info.

                  And my phone needs to have GPS enabled.

                  Comment


                  • #10
                    The weather widget for me has never worked in New Zealand, over 12 months now. I've tried all sorts of tips and fixes to no avail. Accuweathers app also doesn't work, but at least points in the right direction by saying data not available for your location. I'm wondering if Garmin uses accuweather for their data?

                    I know there's nothing wrong with my watch and phone as the weather apps worked without issue or any tweaks as soon as I arrived in Hawaii a few days ago.

                    Comment


                    • #11
                      I had the same problem a few months ago. It resolved itself after a week or so and I believe it was a Garmin server error as my Edge 510 was also "waiting for data" as well as my F3. When troubleshooting, I connected both devices to other sources to check it wasnt an issue wit my phones BT (two phones and a tablet) to no avail.

                      Comment

                      Working...
                      X