Announcement

Collapse
No announcement yet.

Unable to import movie clip into Virb Edit library

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Unable to import movie clip into Virb Edit library

    Hi,

    I'm a Virb Edit user since version 2.x and I really like that tool for GPS overlay of my drone videos.

    Today I was trying to import a new movie I made with my drone like before and the movie clip doesn't import into the Virb edit library. At the end of the import process there is a message "Successfully import of 0/1" so nothing has been imported.

    When I double-click on the movie file it correctly opens and play into windows media player so it's not a codec issue - you can download the movie file here if you want to try : https://www.dropbox.com/s/6web3l9k67...-fail.mp4?dl=1
    I use VirbEdit v 4.2.2 on Windows 8.1 pro
    I also update to the latest (v 5.1.1) but the issue is exactly the same : Successfully import of 0/1
    When I import a photography file (.jpg) it works correctly and the file is successfully imported : Successfully import of 1/1
    The problem is only for movie files like that one : https://www.dropbox.com/s/6web3l9k67...-fail.mp4?dl=1

    I had activate the logging and find that error into : C:\Users\aurelien.goutal\AppData\Local\Temp\VirbEdit\4.2.2.0\app1500388989.log

    Run starting at 18/07/2017 14:43:09
    14:43:09 Debug AVFormatContextHandle_t created
    14:43:09 Warning Duration between stream and formatContext metadata do not match. Using shortest duration, some content may be lost
    14:43:09 Debug AVFormatContextHandle_t destroyed

    I think there is a problem after a windows automatic update so I tryed to uninstall and reinstall Virb Edit in 4.2.2 and then in 5.1.1 version but it doesn't solve the problem at all.

    Please I need help to find a solution.

  • #2
    This problem is technically a bug. VirbEdit is incorrectly expecting your file to have some metadata that it does not have, so it does not import it. I say it is "technically" a bug because while the assumption it is making is not valid in general, it is valid for all videos from any Virb camera. We do not actively attempt to thwart our users from importing videos from sources other than our cameras, but we also aren't actively trying to make a video editor that works with any video from any source (meaning we don't typically expend developer effort fixing problems related to non virb videos).

    That said, I am going to see if I can do something about this particular problem. If it ends up being too problematic, I will have to leave it how it is. Sorry to be the bearer of bad news. If I cannot fix it, and you found that your drone videos worked in prior versions of VirbEdit, that may be your best option.

    Comment


    • #3
      Originally posted by Purdington View Post
      We do not actively attempt to thwart our users from importing videos from sources other than our cameras, but we also aren't actively trying to make a video editor that works with any video from any source (meaning we don't typically expend developer effort fixing problems related to non virb videos).

      I always mix footage from different devices. Such as my smartphone (pictures and videos) with my X & XE.
      Since 5.1.1 I was not able to export a clip anymore, which contains smartphone footage (Virb Edit 5.1 Export Issues).
      Didn?t expect it maybe is related to that.

      It is completely understandable, that Garmin will not develop for free, for different devices from different manufacturers.
      But it worked in the past and was really useful! I hope you'll find a solution to enable it again.
      Devices: Forerunner 405, Vivoactive & Virb X & XE
      GitHub: Read diagnostic system via Bluetooth
      YouTube: My channel
      App: Stretch

      Comment


      • #4
        @HerrRiebmann The problem preventing admin_1 from importing his video has been present since 2015, and this is the first time I've seen it cause a problem, so your export issues probably do not have the same cause.

        I've taken a look at the problem I outlined above and it was a simple enough fix. Unfortunately, it did not quite make the cut off for our next release, so you won't see it in our next maintenance release. The good news (sort of) is that we want to do a few more maintenance releases because we still aren't satisfied with VirbEdit's current state, so you won't have to wait too long to get it.

        Comment


        • #5
          Okay, it was just a guess, that it is related.
          Took a new recording via smartphone and I could export it. My "old" project with my "old" recording (same smartphone) is still not exportable. Even after upgrading to 5.1.2

          Still crazy, but I'm glad that it still works. Just bought a gimbal, which is capable to work with the Virb and my phone and want to use both sources
          Devices: Forerunner 405, Vivoactive & Virb X & XE
          GitHub: Read diagnostic system via Bluetooth
          YouTube: My channel
          App: Stretch

          Comment


          • #6
            I am having the exact same isse. I am using the very latest version of Garmin Virb v5.2.1 and my Garmin Virb ultra 30 itself is on the very latest firmware v4.50. When ever I attempt to import a video I get 0/1 or 0/2 etc... it never imports the video.
            1. I can see the video on the Garmin Ultra 30 - I can run the MP4 and play them.
            2. The source that files are copied to on my laptop is available and there are not permissions issues.
            3. I am using a MacBook Pro with the latest OS installed.
            4. I have successfully imported videos using the same laptop, same camera, same USB cable.. that that is the same. I did updated from firmware 4.30 to 4.50 because the software said it was out of date.

            Comment


            • #7
              Hello deanbuxton,
              If you can share the video file(s) that will not import, I will take a look. PM me the link to your file.

              Comment

              Working...
              X