Announcement

Collapse
No announcement yet.

Rhino 655t stopped working with Windows 10

Collapse
This topic is closed.
X
X
  • Time
  • Show
Clear All
new posts

  • Rhino 655t stopped working with Windows 10

    My Rhino 655t stopped working with Windows 10. When I plug it in I get the USB symbol on the Garmin screen for about 5 seconds and it show up under Windows devices and then it drops. The GPS unit then boots up. I have tried different cables and different computers --both with Windows 10. I have tried reinstalling Garmin Express, Basecamp, and drivers. I have tried changing the input from serial to spanner mode. In spanner mode, it asks me if I want to enter mass storage mode, click yes, same problem happens--I see the USB symbol on the Garmin, the Windows recognizes the USB, then it drops (in about 5 seconds) and the GPS unit boots up.

    Anyone else have this problem? Any ideas on how to fix it.

    Thanks

  • #2
    There are no forums here for device issues like this. Your best bet is to contact Product Support or try http://forums.gpsreview.net/categori...ness-gps-forum
    Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
    Previously owned Etrex Legend H, Mio Navman and used Mapsource
    (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

    Comment

    Working...
    X