Announcement

Collapse
No announcement yet.

Garmin Maps Update stuck at Downloading stage

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Garmin Maps Update stuck at Downloading stage

    I'm attempting to update the maps on my Nüvi 255W, using the Garmin Maps Update application. It's already successfully downloaded a firmware update (which I've applied).

    It is now meant to be downloading the City Navigator Europe NT 2013.10 map update. I have installed an SD card which is big enough to take the update.

    It's been stuck on the "Downloading (2680.8 MB)" stage now for several hours. It looks to be about 11/12ths of the way through but the progress circle has not moved all morning. Activity Monitor says the Garmin Map Update process is using about 13% CPU, so it's doing *something*—but Little Snitch reports no network activity, so it's not actually doing any downloading!

    I don't think it's my broadband's fault (I'm getting 26.75 Mbps at the moment!).

    I'm using Garmin Map Update 4.5.0 on OS X 10.8 Mountain Lion.

    Anybody have a clue what's wrong and whether there's anything I can do about it, other than wait (and wait and wait and…)?

    Thanks, all.
    --
    Glenn

  • #2
    Tried the time-honoured method of 'quit and start again'…

    It's now downloading map data again (though it seems to have started afresh, right from the beginning). For some reason, it now says "Downloading (3619.5 MB)", i.e. it's trying to download more data!

    Will update the thread if/when anything happens…

    Comment


    • #3
      So it's almost half way through the download, according to the blue progress circle. But according to the log, it hasn't actually downloaded anything in the last half-hour. It's effectively stalled.

      I must say, this is very frustrating!

      Comment


      • #4
        …and it's now been almost an hour and half since it downloaded anything…

        The log doesn't show any errors, either.
        Last edited by G_R_S; 08-04-2012, 08:24 AM. Reason: Forgot to mention the lack of errors in the log.

        Comment


        • #5
          I'm not sure if this will work but you can try it. put your computer in safe mode with networking and try running the updater again.

          Comment


          • #6
            city navigator download stuck

            My citynavigator NT europe download to SD has stopped also at 67% its been doing this for a week..after several reboots and formats of SD cards I am out of ideas?

            nik

            Comment


            • #7
              Originally posted by CLARKJOEBOB View Post
              I'm not sure if this will work but you can try it. put your computer in safe mode with networking and try running the updater again.
              Thanks for the suggestion! I'm attempting the update yet again today, and if (I as I fear) it doesn't work, this will be the next thing I try.

              This time I've tried switching off the OS X firewall, just on the off-chance it was interfering (though I doubt it). And I've contacted Garmin Support, who said: "I believe we will need to report this issue to find a resolution as there is no simple solution as of yet."

              The support rep asked for a couple of log files, which I've duly sent off.

              ELBISONTE, if you are having the same trouble, maybe it's worth you contacting Support too. They may think my troubles are an isolated issue (despite there being a number of similar threads on this and other forums).

              BTW, I assume you're a Mac user too…? Are you running Mountain Lion too? Just curious…

              Glenn

              Comment


              • #8
                Well, believe it or not, this time the download and installation WORKED!!!!

                I find it hard to believe that the fix was as simple as switching off the OS X firewall, but that was the only thing I did differently (oh, and I also switched off Little Snitch).

                ELBISONTE, maybe it'd be worth you trying it again with the firewall off too.

                Glenn

                Comment


                • #9
                  Why are you surprised it was a firewall issue ... that's partly why firewalls are there

                  Any time you have a download issue you need to check the download isn't being stopped at the firewall
                  Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
                  Previously owned Etrex Legend H, Mio Navman and used Mapsource
                  (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

                  Comment


                  • #10
                    True, that is what a firewall is for . . . but it seemed unlikely to me that the firewall would prevent the downloading of *some* of the map update files but not *all* of them (especially as they all seemed to be coming from the same server). Also, there were no "help, the firewall won't let me download stuff!" errors in the Garmin Map Update log file, nor were there any Garmin-related messages in the system log files. So it didn't look like the firewall was causing a problem. I only switched it off on a whim! Computers, huh?

                    Glenn

                    Comment


                    • #11
                      Hi Glenn,

                      I appreciate you noting all of this down about your Garmin product cause I'm experiencing the same problem with my Garmin nuvi 255W GPS. I have been trying to update my maps but it has been on 55% percent for a whole day now and don't know what to do. I followed your advice and checked if my firewall was off...and it was so I don't know what the problem could be.
                      Do you have any further suggestions for me?

                      Comment


                      • #12
                        Hi SUMMERTAN21,

                        Sorry to hear you're having the same trouble I had! It's very frustrating. Are there any errors in the log file? (I found it in ~/Library/Caches/Garmin/ —if you're using Snow Leopard or later, the ~/Library folder is hidden in Finder by default, so to open it you'll need to use the "Go to Folder…" option in Finder's Go menu.)

                        I'd recommend you contact Garmin Support and raise the issue with them. It seems that a number of Mac users are having this problem, so the more noise we make, the more likely they will give someone the job of looking into the problem. Also, it may be a coincidence, but my download worked after I'd contacted Support and sent them my log files. Could be fluke, though.

                        I guess my other piece of advice would be to just try again another day. Maybe the servers get overloaded or something...?

                        Glenn

                        Comment


                        • #13
                          I had the same issue on a PC, stuck at 99% updating, so I disconnected from our corporate network (which is heavily firewalled), and connected outside our network, the update then completed in a minute or so. Something towards the end of the map update must try to do something that is different from the first 99% of the download, possibly sending info back to Garmin on some typically blocked port.

                          Comment


                          • #14
                            Update progressed!

                            Hey guys I've just experienced the "stuck" download problem as well but I've found the solution, which might not be the same as what y'all are experiencing. Basically the problem I ran into was that the firmware was "finalizing" and when I came back after an hour it was still at the same stage!! Then saw the instructions on the left saying it needs to be reconnected to finish installing. So I thought maybe turning the device off and on would work. Lo and behold the update progressed! All this time the USB has been connected as I was afraid of losing data as well. Saved time not needing to contact Garmin
                            I've got a Nuvi 1350 and had it since 2011 and it's still going strong. If I can some how overclock the CPU it would be a beast but it's still relatively fast for an oldish model

                            Hope this helps future readers

                            Cheers

                            Comment


                            • #15
                              I do have the same problem downloading TOPO Map for Poland.
                              It stucks always, even when i am switching off the Firewall (BitDefender).
                              It stucks at 4, 7, 14, 30% it differs very often, but so far i was not able to download this map.

                              Bernhard

                              Comment

                              Working...
                              X