Announcement

Collapse
No announcement yet.

GPSmap60CS Connected device not correct - thinks is a 276C device

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPSmap60CS Connected device not correct - thinks is a 276C device

    I just connected my GPSmap60CS to BaseCamp on my Mac, it recognizes the device correctly but EVERY user guide, refernce guide etc.. is for the GPSmap276C device!

    id like to update my device but am unable to do so.

    Anyone run into this?

  • #2
    Hello Rich,
    I do not have or use a MAC so these programs might not be available to you.
    On Windows you would need to use Garmin Express to update your 60S. If that does not work then download and install Garmin WebUpDater.
    Hopefully a MAC guru will have better advise
    Don Huston
    San Diego, CA.
    United States

    Comment


    • #3
      Good advice from DATEZZ.

      GARMIN Express is available for the Mac OS
      cheers... jack

      04 BMW R1100S
      02 KTM 250 Exc Racing


      SmugMug referral code: jXF8ohDWlTm56

      Comment


      • #4
        hi
        It's not possible with Garmin Express, you must use Webupdater

        Comment

        Working...
        X