Announcement

Collapse
No announcement yet.

Forerunner 310XT failed to transfer data

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Forerunner 310XT failed to transfer data

    I took the plunge and purchased the 310XT exactly a week ago today. I love the features of the device and the installation was a cinch, everything just worked and I was especially pleased to see that Garmin have invested in factoring in Mac compatibility, where many other manufacturers don't bother.

    Transfers were working seemlessly until last night when, after performing two activities during the day, I brought the device within range of my Mac, the ANT agent fired up, the watch buzzed but I was promptly greeted with "The last data transfer from device xxxx failed". And that's where a 4 hour saga to try and resolve the issue began...

    I scoured the web and garmin forums for clues, performed several uninstalls, reinstalls, reboots, soft resets, unpairing, repairing in all sorts of orders, but to no avail, I even installed everything onto a PC, but that too failed, which indicates the device was at fault.

    An answer (not ideal, but works):
    I eventually resolved to perform a hard reset and lose my day of activities. No sooner had I done this and we were back in action. My run this morning has already synched and I'm back on track, but for how long???

    What next?
    From the troubleshooting I carried out, I suspect that there was some corrupt data within one of the activities I'd performed that day, or botht eh PC and Mac ANT agents are at fault.

    I contacted Garmin support who said to regularly synchronise my data to avoid losing too many activities. That's not an acceptable answer in my mind for such an expensive device boasting to store hundreds of historical activities and doesn't bode well for my two weeks on holiday without my computer to sync it too.

    Any chance of a firmware/software upgrade?
    Perhaps a firmware upgrade might help fix this, or perhaps the ANT agent is causing the issue. Either way, I know I, and many others (having seen the number of people experiencing this), would be very grateful of any support from Garmin on this, as it's not a great start to such an anticipated product release.

  • #2
    I believe this issue is a data corruption issue that has been resolved and will be fixed in the next firmware update.

    Comment


    • #3
      Originally posted by BBECKER39 View Post
      I believe this issue is a data corruption issue that has been resolved and will be fixed in the next firmware update.
      Thanks for the response, that makes a lot of sense. I'll keep an eye out for it but is there any indication when this might be released? I'm worried I'll come back from two weeks away in September and lose every training session...

      Comment


      • #4
        There was me feeling a little smug that I had not experienced any data transfer problems. And then it happens. The garmin hung transferring data. I only had 2 activities in the device so, after trying various things like reboots and reloads of ANT Agent, I deleted the one activity that was only a 1 lap run. Lo, the data transfer then completed of the remaining activity.

        Strange really as I would have expected problems with the more complex multi-lap bike ride.

        Is anyone in Garmin prepared to give a date when we can expect new firmware to resolve this?

        Comment


        • #5
          A little more information.

          Despite appearances, the remain activity was not being uploaded. The ANT Agent reported a successful transfer, but the activity itself did not appear in the History folder or GTC. There was a .FIT entry for the activity. After a couple more attempts yielding the same result, I deleted ALL the Ant Agent files in <User>/Library/ApplicationSupport/Garmin and reinstalled the ANT Agent.

          Lo, then there was success. The activity appeared in GTC and I was able to upload it to RunSaturday.com

          Maybe, in this instance anyway, the problem does lie within the ANT Agent software/files and not in the 310XT.

          Comment


          • #6
            Also Experiencing Transfer Problem from 310xt to MB Air

            Day 1 using my new Forerunner 310. Everything great until I tried to transfer data.

            Have tried to troubleshoot for last 2 hours. Uninstalled and reinstalled several times. Followed the "corrupt data" theory here and and deleted my only saved workout. Created a second workout and it also failed to transfer.

            Any suggestions? Starting to lose excitement for my new Garmin device.

            Update. Just tried to hard reset which has seemed to work for some. Did not resolve data transfer issue for me.
            Last edited by GEOFFD12; 08-23-2009, 07:50 PM.

            Comment


            • #7
              same problem

              Same problem here with uploading from my device and mac for more then two weeks now. I have contacted the helpdesk, but so far no answer and help. Hopefully it will be solved soon.

              Comment


              • #8
                Originally posted by GEOFFD12 View Post
                Day 1 using my new Forerunner 310. Everything great until I tried to transfer data.

                Have tried to troubleshoot for last 2 hours. Uninstalled and reinstalled several times. Followed the "corrupt data" theory here and and deleted my only saved workout. Created a second workout and it also failed to transfer.

                Any suggestions? Starting to lose excitement for my new Garmin device.

                Update. Just tried to hard reset which has seemed to work for some. Did not resolve data transfer issue for me.
                What kind of data did you have in your device after a hard reset? Did you recreate the workouts or did you have any other activities stored in it?

                Comment


                • #9
                  Originally posted by EDOVONK View Post
                  Same problem here with uploading from my device and mac for more then two weeks now. I have contacted the helpdesk, but so far no answer and help. Hopefully it will be solved soon.
                  How about your ANT USB key? We're lucky to have 2 x 310s in the house because we had an issue with one of the USB keys. Problem with ours was that it would work fine on the MAC but not with the WIndoze laptop. The other USB key worked fine on both. Sent it back to the shop we bought the Garmins from and got a replacement. Works fine on both now.

                  I am sure there are some posts around here about faulty USB keys. The shop also mentioned that they ahd a number of keys returned for replacement so clearly the problem is not unique.

                  Comment


                  • #10
                    I am currently experiencing the same problem. My last date transfer was on Aug 20th as well. I have since done several activities and none of them have transferred. I did a triathlon with it yesterday and that will not transfer. I do not want to erase the data from this race if I can avoid it. I have unpaired and re-paired the devices twice. The watch will say it is transferring data, but everytime the ANT says it has failed.

                    I have just read through all of the posts and realized that Aug 20th was the first time I put it in BIKE mode for a ride and that was the last transfer date I had success with. Prior to that I had been using it in run mode on the bike. Other posts mentioned that the most trouble was coming out of the Bike mode; I wish I had known that on Aug 19th.
                    Last edited by GILESC1029; 08-24-2009, 04:52 PM.

                    Comment


                    • #11
                      The data getting corrupted on the watch has been related to using the device in the BIKE mode and this has been fixed. There should be a firmware release coming soon for the 310XT with the fix.

                      Comment


                      • #12
                        But the data I could not transfer the other day was a run!! I deleted the run - because it was only one 1 lap and had the information I least wanted to lose. The bike data, recorded the same day, before the run, transferred fine and that was multi-lap.

                        Comment


                        • #13
                          Originally posted by PHILIPSHAMBROOK View Post
                          There was me feeling a little smug that I had not experienced any data transfer problems. And then it happens. The garmin hung transferring data. I only had 2 activities in the device so, after trying various things like reboots and reloads of ANT Agent, I deleted the one activity that was only a 1 lap run. Lo, the data transfer then completed of the remaining activity.

                          Strange really as I would have expected problems with the more complex multi-lap bike ride.

                          Is anyone in Garmin prepared to give a date when we can expect new firmware to resolve this?
                          It seems like you were having a different problem altogether. If the device had been corrupted, only a hard reset and not deletion of activities would fix it.

                          Comment


                          • #14
                            So, are you saying the device is getting corrupted, not the data in the device?

                            In which case, how will the firmware fix the problem I experienced? I do understand that without the corrupted file you cannot see where the problem was, but then, if I could not get the file of the 310, how would we look to resolve this problem?

                            It does seem a little intermittent, as the problems I have experienced are few and far between. I am a happy user : overall. (I did put lots of smiles but only allowed 4)

                            BTW, my wife and I biked and ran the same time and she experienced no problems uploading data. That makes it a reasonable assumption that only the data on my 310 was at fault, or only my 310 of course.

                            Comment


                            • #15
                              If you see similar issues with download in future, kindly look for files in a folder BadFitFiles/ in Garmin/Devices/<unit id>/ once GAA indicates transfer failure. That would be an indication of a corrupted data in your watch.

                              Comment

                              Working...
                              X