Announcement

Collapse
No announcement yet.

Music stops working

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Music stops working

    Has anyone else had an issue with the 654M (v2.50) in which the music will stop randomly after a song finishes? I've noticed it on every run over the past week or so. Sometimes it will happen after a couple of songs, sometimes not until 30 minutes into the run. Not the same song either. I've loaded a few hundred songs via Garmin Connect but have over 1.5 GB still free.

  • #2
    Do you notice that when the music stops the same type of event is occurring during the activity? Such as Audio Prompt, Auto Lap, or Smart Notification?

    Or do you see the music stop randomly and if you press play does it start again?
    Garmin Product Support

    Visit the Support Center
    www.garmin.com/support

    Comment


    • #3
      Is it always at the end of a song? Are the headphones still connected to the watch (check sensor settings)? Do you have audio alerts on? does the silence coincide with an alert? Are you playing all songs, or an album, or some other way?

      By the way, I haven't had this just trying to guess what might be happening

      Comment


      • #4
        It seems to happen at the end of a song. I have Shuffle All selected and Repeat off. I haven't noticed it coinciding with another event but will pay closer attention. It happened again today but this time, along with the music stopping, the activity paused. I was doing a Treadmill run and was 2.15 miles into it. I noticed that the music had stopped and glanced down to see that the run was paused. I restarted the run but couldn't get the music to restart. I've tried Pausing and Playing, Skip Forward and Back, all with no luck. I couldn't get it to restart and didn't want to reboot the watch because it would have interrupted the run.

        I don't think it is a problem with my headphones (Aftershokz Trekz Titanium) which have been working fine. I ended up switching the headphones to my iPhone and they worked fine the rest of the run.

        Comment


        • #5
          Did you happen to notice is your device rebooted when the music stopped and activity was paused?

          If you see any err_log.txt or err_log.bak in the Media>Garmin>Debug folders when connected to a Windows PC, can you post attached the so we can take a look?
          Garmin Product Support

          Visit the Support Center
          www.garmin.com/support

          Comment


          • #6
            Originally posted by Garmin-Joey View Post
            If you see any err_log.txt or err_log.bak in the Media>Garmin>Debug folders when connected to a Windows PC, can you post attached the so we can take a look?
            Garmin-Joey can you please talk to your firmware developers and have them automate this process of collecting error logs? You guys need to get as much stats on the reliability of your FW and automation is the only way to go ...

            Comment


            • #7
              I have the completely same issue as jnljones. Same headphones (Aftershokz Trekz Titanium), same watch (654M - v2.50).

              Comment


              • #8
                I'm having the same issue as well. I'm also experiencing where a song will start to repeat and won't stop repeating. And yes, I have the repeat option turned off. Once this happens the skip forward and backward buttons don't work. I have to go into the playlist and start on a different song. It will finish that song and then play another song and then it will start repeating that song. I've yet to get through a run without this happening so very frustrating... Audio alerts are disabled. Playlist were created using iHeart radio. Bose Soundsport earbuds. 645m -v2.50

                Comment


                • #9
                  I'm having an issue similar to what you're talking about. However, my 645M stops playing music after each lap announcement and won't play music again unless I stop power down and restart. This just started happening about a week ago.

                  Comment


                  • #10
                    Originally posted by DavidCPaquet View Post
                    I'm having an issue similar to what you're talking about. However, my 645M stops playing music after each lap announcement and won't play music again unless I stop power down and restart. This just started happening about a week ago.
                    Same exact issue. Aftershokz Trekz.

                    Comment


                    • #11
                      Yes same issue here. Along with many other issues with the watch (reboot nearly every activity etc) now on my last few runs a track will finish and then silence. I look down at the watch assuming it's another reboot but the watch is still recording the run. While on the move I go into the music screen and press play and then the next track starts the rest of the playlist continues. I'm using TomTom bluetooth headphones and a playlist downloaded from iTunes. It's only started to happen since Sunday I think. It doesn't coincide with audio prompts or anything else obvious.

                      Comment


                      • #12
                        Yes same issue here..

                        Stops working after hour or so at end of track. also the activity pauses. Activity restarts fine but unable to pair headphones unless restart device

                        v. 3.10
                        Aftershockz air
                        Last edited by Leew72; 06-05-2018, 07:35 AM.

                        Comment


                        • #13
                          Similar Issue here

                          Brand new 645M, with Skullcandy Methode Wireless BT
                          Did a run with the default garmin app, and played music through the headphones.

                          After exact 20 minutes te music stops, I heard 1 audio lap alert and then i wanted to start the music again, so i pressed the down button for some seconds to go into music mode. Saw the last music file, and then everything freezed. Nothing anymore. Buttons not working anymore.

                          Had to reset, by pressing the light button for about 15 seconds.
                          After that everything was recorded until 20 minutes (until the freeze) ,all the rest is lost.

                          Did a call to garmin Netherlands , because i wanted to check my logs, but they were not interested in my story.
                          They told me, if it was a firmware problem then i had to know it because there are so much devices in the world.
                          He told me; if it will happen again then the memory is stuck and need to replace.

                          I'm not interesting in the information from garmin, because i still think this is a firmware bug.

                          So garmin FIX IT! i'm not alone!


                          Comment


                          • #14
                            Same issue as OP: music will stop 20-30 minutes into run at the end of a song, but watch will continue to record run. Music will not restart regardless of what I attempt with the music settings (Play, FF, RW) - even if I go to My Music and re-select the playlist on the watch, it won't restart. Am listening on shuffle. I haven't tried to restart watch in the moment because it will erase my activity info. Audio prompts during the run stop working as well once music stops. Jaybird X2 headphones stay connected the whole time. FW version 3.10 (*updated to reflect correct FW version*). Device does not reboot - just won't start playing music again no matter what I do. Have to finish my run in silence. Issue does not appear to coincide with any other activity or prompt.

                            Getting REALLY TIRED of serving as a beta tester for Garmin. Went through 2 Vivoactive3s with inaccurate gps before purchasing the 645M. Not happy about paying $450 for a device that doesn't work as it should. Apple Watch Series 3 with a Scosche strap (that I already have) is looking really good right now.
                            Last edited by flong2000; 06-05-2018, 03:01 PM.

                            Comment


                            • #15
                              The 3.30 FW started being sent out today, and it sounds like it fixes the problem you are having. See the sticky at the top of the forum.
                              My Connect IQ Apps in the Store
                              Facebook - Instagram -
                              Twitter

                              Comment

                              Working...
                              X