Announcement

Collapse
No announcement yet.

310xt won't turn on . . . help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 310xt won't turn on . . . help

    My 310xt was fine but wouldn't upload data, so I did a soft reset (mode & lap buttons), still didn't work. I took it outside (synched with gps) and powered off. Now it won't turn on, it won't even charge. How do I hard reset this guy? I have a race tonight.

    Thanks in advance

  • #2
    For a complete reset, press mode and power button at the same time.

    Comment


    • #3
      Thanks. Still no response from the 310xt.

      Comment


      • #4
        Just to be sure, use the power charger that plugs into a power outlet, not your computer's USB port. If you're not even getting anything when it is plugged into the charger (should at least say charging), then your best bet will be to call Garmin phone support. They might be able to get your device working before your race.
        Phil M.
        myConnect | StravaHeatmap | Instagram
        F201 F205 F305 FR50 310XT 920XT
        nüvi 67LMT

        Comment


        • #5
          Thanks. I've tried USB, regular power, a different charger (my wife has a 405). The 310xt is lifeless even when plugged in. Every button combo I can think of to reset (even the one that used to work on my 205). Now I am just waiting until garmin customer service opens or until the store I bought it from and can hopefully exchange it first.

          Comment


          • #6
            Try doing the hard reset while you're waiting. You will lose all data from the device and it will be restored to day 1, factory defaults (hopefully). Hold down mode while turning on power, then let both buttons go. You will get a prompt asking you if you want to erase all user data.
            Phil M.
            myConnect | StravaHeatmap | Instagram
            F201 F205 F305 FR50 310XT 920XT
            nüvi 67LMT

            Comment


            • #7
              If the hard reset doesn't work, try the "unprompted" hard reset. I have not tried this on my 310, but it works on the 305.

              Kudos to kansaiben for this fix:
              Hold down enter and mode while quickly pressing the power button (do not hold the power button). Continue to hold enter and mode for a few more seconds. You should see the screen barely flicker on when you push power, and then nothing else should happen until you release the enter and mode buttons. After you release the buttons, your unit should power up and go through the initialization screens. Since this can be a difficult sequence to do, it is best to keep trying a few times if it doesn't work at first.
              Phil M.
              myConnect | StravaHeatmap | Instagram
              F201 F205 F305 FR50 310XT 920XT
              nüvi 67LMT

              Comment


              • #8
                same for me ...

                Brand new 310xt, three weeks old.
                Everything worked fine until today when the 310xt would not turn on anymore.
                Nothing to do, even the powering does not show anything. The beast it out of service.
                I sent it back to Garmin France ...

                Comment


                • #9
                  I had the same problem and hard reset worked for me thanks.

                  Comment


                  • #10
                    Originally posted by CAIOHB View Post
                    I had the same problem and hard reset worked for me thanks.
                    I had/have the same problem but the hard reset doesn't work.

                    This does not portend well for the device.

                    It has only been like a week and a half using the device.

                    Comment


                    • #11
                      Originally posted by MIDKNIGHTR View Post
                      I had/have the same problem but the hard reset doesn't work.

                      This does not portend well for the device.

                      It has only been like a week and a half using the device.
                      I am NOT HAPPY with the customer service on this matter. On top of all the run around and unanswered emails and over the phone promised help which was never sent - on top of that they now want me to send them the watch and everything from the box, with insurance (though since it's broken it seems like a scam to buy insurance, ...hey what do ya know it's broken, give me money?), anyway they want me to send that at my own cost!

                      Comment


                      • #12
                        Originally posted by MIDKNIGHTR View Post
                        I am NOT HAPPY with the customer service on this matter. On top of all the run around and unanswered emails and over the phone promised help which was never sent - on top of that they now want me to send them the watch and everything from the box, with insurance (though since it's broken it seems like a scam to buy insurance, ...hey what do ya know it's broken, give me money?), anyway they want me to send that at my own cost!
                        Why don't you deal with the retailer? It's the first port of call fo us over here. Since they want my future business and recommendations, they are usually very responsive and helpful.

                        Comment


                        • #13
                          Originally posted by PHILIPSHAMBROOK View Post
                          Why don't you deal with the retailer? It's the first port of call fo us over here. Since they want my future business and recommendations, they are usually very responsive and helpful.
                          Definitely should have and will do in the future! Geesh I finally got a replacement. If this one spontaneously blanks and won't turn on, I swear my head might explode!

                          Comment


                          • #14
                            Blank screen, has been plugged in

                            Went to use my 310 today. It has been plugged in and all I get is a blank screen. Moved around the house and tried different outlets. Nothing.

                            Tried the hard reboot. Nothing.

                            I can't stomach the thought of dealing with their terrible customer service.

                            /cry

                            Comment


                            • #15
                              I've had my 310XT for 2 months and for most of that time it has been working fine (other than changing the units from metric to statute without prompting).

                              I turned it on yesterday for a run and it was fine. I did my full warm up, including a light jog. I then went into Training->Courses and chose a course to do. As soon as I hit Enter on "Do Course" it powered off. Every time I powered it on, the Garmin scree would show briefly and then it would turn off. I connected it to the charger and it flashed on for a second and off again (it had 96% charge).

                              My only solution was a hard reset - which mean reentering all my data and loading all my workouts and courses again.

                              Firmware is 2.90.

                              Comment

                              Working...
                              X