No announcement yet.

Minor issue uploading to Garmin Connect

  • Time
  • Show
Clear All
new posts

  • Minor issue uploading to Garmin Connect

    The answer may be out there somewhere in the Forum, but I can't find it and I'm starting a new thread.

    I have a Garmin 310XT and compared to most people on the forums, I have had no problems with it. I have upgraded to the newest software and I have let the unit the discharge completely before recharging, and so far, so good. I am very pleased with the unit.

    The only problem that I have is that my ANT agent is missing the "Authorization Key" to connect to Garmin Connect. Somehow in my initial setup, that step was missed. When I download from my 310XT, I get a message that the transfer to Garmin Connect failed. I can then go to my dashboard in Garmin Connect and I can upload my data.

    It is irritating that Garmin Connect can get my data, even though the initial transfer from ANT fails because of a silly, paranoid thing around the security of my ANT agent. I did see a Garmin FAQ about how to delete a GCAuthorizationKey.bin file for a Mac application. With this key deleted, you should be able to get the initial authorization screen when you download a new workout.

    I do not see the same file paths or the same .bin file when I look at my system. I have Windows Vista and I need to know what .bin file in what folder to delete on my system to get back to the initial authorization screen. The only .bin file I see is a ANTDeviceKey.bin file. I am leary about deleting wrong files and causing more problems than I already have.

    This is a minor problem because the download doesn't work as far as ANT is concerned, but I can then upload from Garmin Connect and get my stuff. I did email Garmin Support a few weeks ago about how to fix this and got no response. This is another reason for the new thread. Again, I am very happy with my unit.

    I sympathyse with those who have had major problems with their 310 and have lost workout data or have had to return their units after struggling with them.

    Thanks for any input.

  • #2
    I would just re-pair the device and re-authorise. Remove it form ANT Agent first.


    • #3
      Check out this thread:

      I've quoted one of the posts below. The other thing is to make sure you don't have a firewall keeping Ant Agent from opening the browser to complete the authorization.


      You will need to delete the GCAuthorizationKey.bin file in the GARMIN\Devices\[device_id] directory (see below for location of this directory).

      When you do that, the next time you get data from your device, your browser should pop up asking you to log in to Garmin Connect.

      Originally posted by KANSAIBEN View Post
      This type of question comes up fairly frequently. When the ANT agent downloads copies of your activities from your fitness unit they are stored locally on your hard drive before sending to Garmin Connect and/or Garmin Training Center. Depending on your OS, these files can be found in the following locations:

      Windows XP:
      C:\Documents and Settings\[username]\Application Data\GARMIN\Devices\[device_id]\History

      Windows Vista:
      C:\Users\[username]\AppData\Roaming\GARMIN\Devices\[device ID]\History

      Macintosh HD/Users/username/Library/Application Support/Garmin/Devices/[device id]/History

      Note: In the locations above, items in brackets "[ ]" would be replaced with your actual user name and device ID number. Recent versions of the ANT agent will store up to the previous month's worth of downloads before they start to be overwritten. On Windows computers, the application data folders are hidden by default and you will need to enable the viewing of hidden files in your folder options before you will be able to see these items.

      How to show hidden folders in Vista
      How to show hidden folders in XP

      History files will have the .tcx extension. For some units, the device also stores history in another location/file format. These files can be found in the "Activities" folder and will have the .fit extension.


      • #4
        Thanks for the response. I set up my computer to show hidden files and I followed the path for Windows Vista to find my device ID folder.

        However, under my device ID folder, I could not find a file anywhere called GCAuthorizationKey.bin, the only file that I could find that sounds similiar is called ANTDeviceKey.bin

        Would that be the file? I thought about moving it to another folder instead of deleting it in case I would have to restore it. I am afraid about messing things up.

        Thanks for your help.


        • #5
          Remove from the device settings

          I would recommend removing the device from the "device settings" option on the Ant Agent icon on the device system tray and then repairing the watch again.



          • #6
            I tried the last recommendation of deleting the device from my ANT Agent and then repairing. The results were the same.

            What happens is that I first get a message "Unable to open Internet Browser". I click on retry and then the 310 downloads the data to the ANT Agent. After the data is downloaded to ANT, I then get a message "Encountered an invalid Garmin Connect authorization key. Repeat Garmin Connect authorization process. Contact Garmin Support." When I click cancel, the ANT Agent indicates that the data transmission failed. But when I go to Garmin Connect, I can then upload my data OK.

            The good news is that I can see my data in Garmin Connect. The bad news is that the process is not right and it's a little awkward. Also, in the folder
            "Garmin Connect\Pending Uploads" it lists all of my workouts, like it thinks that they haven't been sent to Garmin Connect.

            My Windows firewall was shut off. I did enable it but I put ANT Agent as an exception so that should be OK. My Internet Explorer lists Garmin Communicator Plug-In as an add on, so I think I'm OK there. I don't know what else to check on my browser. I still think that there is a .bin file that I need to find and delete to get back to the initial authorization screen.

            Any other thoughts would be appreciated. Thanks.


            • #7
              Internet Explorer Version?

              What version of Internet Explorer are you using?


              • #8
                See this post regarding Vista uploads:

                May need to adjust your security settings.

                My GC Digest


                • #9
                  I finally got it to work!

                  From the last post, I tried listing as a trusted site and that did not make a difference.

                  I then upgraded from Internet Explorer v7 to IE v8. I deleted my 310 from the ANT Agent and then repaired. Then I got the initial authorization page which I never got before. Now my ANT Agent sends it directly to Garmin Connect and shows a successful transfer.

                  Thanks everyone for your help! What a struggle!