No announcement yet.

Approach S1, "no courses near"

  • Filter
  • Time
  • Show
Clear All
new posts

  • Approach S1, "no courses near"

    I received the Garmin S1 Approach two weeks ago. Out of the box it worked great and was able to locate 4 golf courses within 10 miles of my home. I saw there was an update available (v2.20) and installed it. We then drove 225 miles south for warmer weather. Now, all it will do is inform me that "no courses are near." Odd, since we're actually staying in a condo ON A GOLFCOURSE. Even a course on the Garmin list of supported courses.

    Very frustrated, obviously. I'm wondering if a file was corrupted by the update. Did the distance mess it up? Is it fixable by me? Can Garmin do a remote flash, master reset? Can I roll back to version 2.10?

    I've tried everything I can think of doing. Pressed "menu" + "down" to 'reset', tried re-installing the update from both a Mac and Windows 7, rebooted the watch 30+ times, powered it off and on as many times.

    Any ideas are welcome

    Today (4/4/11) I worked with Garmin Support. Incredibly competent and were able to get the device working. Garmin Support should test/review products and processes like updates/documentation before it goes live. They really know the product. Very impressed.
    Last edited by divotmeister; 04-04-2011, 03:51 PM. Reason: update

  • #2
    Exactly the same issue for me - bought 3 days ago and worked fine straight out of the box.

    Installed Garmin course update now get 'no courses near' message.

    Have contacted Garmin support but if anyone has a solution to this I would be grateful.



    • #3
      any solution for "No Courses Near"

      I updated the software and maps and now the Approach S1 states "No Courses Near" after locating satellites even when standing on known courses. Very frustrating product so far....Don't update your S1!!!!


      • #4
        Approach S1 "No Courses Near"

        Need to rewrite the maps/courses data file correctly regardless if MyGarmin or Communicator tells you that the S1 courses are up-to-date. This seemed to resolve the issue for me.


        • #5
          I've had the same issue and all support say is "do a master reset" and this problem doesnt happen very often (if at all).

          Originally posted by JKSTOX View Post
          Need to rewrite the maps/courses data file correctly regardless if MyGarmin or Communicator tells you that the S1 courses are up-to-date. This seemed to resolve the issue for me.
          I'm a bit of a numpty I'm afraid - would love to resurrect my S1 and not bother support any more - what does "Need to rewrite the maps/course data file correctly...... this seemed to resolve the issue for me." mean exactly!

          HELP please!


          • #6
            S1 approach 'no courses near'

            This issue has also affected me. Straight out the box and this device is a great piece of kit, once you update, then the trouble starts!!! I have attempted numerous master resets and updates, but still no joy. I have been lucky enough to connect twice since original update, once was in the car to work, and the other was at home late at night. Both of which were complete unappropriate times!!! I have emailed garmin twice (reply states you will receive feedback within 3 business days) this was over two weeks ago and still nothing. This product has the potential to be a fabulous purchase, if i could only get the bloody thing to connect!!!

            As i am not technically minded regarding pc's etc, could some genius please explain any fixes (in simple detail) that could refresh this annoying problem??

            Kind Regards
            Another Irate Customer


            • #7
              Approach S1 'no courses near'

              Finally got through to Garmin UK customer services today after many attempts. The guy that answered the call knew exactly what the issues were with the Garmin S1 Approach (I guess theres been a few) and he immediately sent me an email of how to restore the device. The email contained a compressed rar file and a detailed explanation sheet of how to restore this product. Since formating my device and putting the correct files to it, I have been able to connect to the 10 nearest courses to my home. This watch has not been tested whilst on the actual tee box fingers crossed!!!!!!!!!

              Another Happy Customer.


              • #8
                S1 Approach - No courses near after map upgrade

                I had the same problem and requested email support. I actually deleted some files and resolved the problem before I got the response from Garmin but the instructions in the attachement (from Garmin) should fix it for you.

                Its worked great since - I've just come back from Spain and used it across 6 courses and found it very useful! I didn't update the time automatically like it was supposed to do though!


                • #9
                  S1 Approach

                  Not sure if my last post attached the file I mentioned - here's another attempt.
                  Attached Files


                  • #10
                    I had that yesterday. I powered off the device (by holding down the Light button) and powered on again, said was locating sats and then OK again.


                    • #11
                      I had the same problem and called Garmin tech support. They sent these instruction and voila it works fine now
                      In order to obtain this update for the Approach:
                      1.Plug Approach into computer
                      2.Download Garmin CourseView Updater
                      3.Launch Garmin CourseView Updater
                      4.Follow onscreen instructions to update device firmware and/or mapping
                      5.Whenever disconnecting the device: 1.If using a PC, Navigate to (My) Computer
                      2.If using a MAC, Navigate to the Desktop
                      3.Right-click on the device drive/volume
                      4.Select Eject
                      5.Wait for the device to dismount (approximately 30 seconds)
                      6.Unplug device

                      Following these instructions will ensure the latest firmware and mapping is in the Approach.


                      • #12
                        How do you format the approach s1