Announcement

Collapse
No announcement yet.

Windows 8 + Google Chrome = Garmin Connect Unusable

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 8 + Google Chrome = Garmin Connect Unusable

    Hello all,

    I recently upgraded to Windows 8 and I'm struggling to get Connect / Communicator to play nice with Google Chrome. When I reach the Connect login screen, I'm presented with the message
    "Some Garmin Connect features will only work when you use Chrome on the desktop."
    Similarly when I click the Upload button, rather than seeing the Communicator plugin, I see the following message:
    "This page requires the Garmin Communicator Plugin. Please open Chrome on the desktop to continue."
    The problem is, I am using Chrome 'on the desktop'. The test page on the Communicator website works fine, and the plugin works on other websites. It is just Garmin Connect that is playing up. The plugin also works fine in Internet Explorer.

    Any thoughts / ideas?

    Thanks,

    Stuart

  • #2
    I Too am having the same problem with chrome on Windows 8

    Firefox works ok tho.

    Comment


    • #3
      Originally posted by JNEX26 View Post
      I Too am having the same problem with chrome on Windows 8

      Firefox works ok tho.
      I have just upgraded (new clean install) my system to Windows 8 and found that after installing the Communicator on the system I got a DLL not registered JIT exception (after successful install clicking the finish). When opening Chrome now and logging into the Garmin site to upload my workouts I get the "This page requires the Garmin Communicator Plugin. Please open Chrome on the desktop to continue." Even though its installed correctly (according to the install dialog) and using the Chrome desktop version.

      Any bright individual out there that's got a fix for us please.

      Thanks

      Comment


      • #4
        Originally posted by RIGHARDT View Post
        I have just upgraded (new clean install) my system to Windows 8 and found that after installing the Communicator on the system I got a DLL not registered JIT exception (after successful install clicking the finish). When opening Chrome now and logging into the Garmin site to upload my workouts I get the "This page requires the Garmin Communicator Plugin. Please open Chrome on the desktop to continue." Even though its installed correctly (according to the install dialog) and using the Chrome desktop version.

        Any bright individual out there that's got a fix for us please.

        Thanks
        No fix, but I think it is something that Garmin have changed on their end recently. I've been using the final, RTM version of Windows 8 with Chrome since the start of September. It's only this weekend that I've had the same problems as above. I keep getting the "You must use Chrome in Desktop" message, even though I already am and the "This page requires the Garmin Communicator Plugin" message. I also got the same message in IE. I'm guessing that Garmin must have changed something on their end because I can still "see" the Garmin device from other websites like Strava and Runkeeper.

        The easiest workaround I found was to import the rides/runs from my Device into Strava (which worked fine using Chrome and the plug-in) and then export them as a .GPX from Strava and reimport them manually into Garmin Connect. It's a pain in the bum, but it does work, keeps your records uptodate and hopefully Garmin will get it fixed this week!
        Last edited by mrhunnybun; 10-28-2012, 05:50 AM. Reason: typo

        Comment


        • #5
          Originally posted by MRHUNNYBUN View Post
          The easiest workaround I found was to import the rides/runs from my Device into Strava (which worked fine using Chrome and the plug-in) and then export them as a .GPX from Strava and reimport them manually into Garmin Connect. It's a pain in the bum, but it does work, keeps your records uptodate and hopefully Garmin will get it fixed this week!
          Same problem here except I was able to use the "Manual Upload" button and load the .fit directly from the Garmin/Activities folder.

          Comment


          • #6
            I am having the same problem too, please take the time to report the problem to Garmin so they know it needs fixing

            Comment


            • #7
              Same problem here, Chrome + Windows 8, the communicator plugin works with Endomondo...

              Comment


              • #8
                Same thing here on Windows 8 formal release with all latest updates - communicator plug in says all working well but "This page requires the Garmin Communicator Plugin. Please open Chrome on the desktop to continue" shows when go to upload screen. Garmin Connect then cant see the device and offers manual upload. tried updated to use chrome beta channel to get any later software from Google but not luck - using Chrome V 23.0. Same thing using IE. Very annoying !

                Comment


                • #9
                  Exactly same scenario for me with Chrome + Garmin Connect on Windows 8. They do not play together anymore. Anyone know if Garmin is working on this?? It is still possible to use manual upload, though.

                  Comment


                  • #10
                    Originally posted by KINGFISHERDK View Post
                    Exactly same scenario for me with Chrome + Garmin Connect on Windows 8. They do not play together anymore. Anyone know if Garmin is working on this?? It is still possible to use manual upload, though.
                    me too, just bought new lap top with windows 8 and this is naff. I should have stayed with windows 7 as so many issues tonight that i never had on previous version

                    Comment


                    • #11
                      Same here, the install has totally screwed windows 8 all I have now is a black scree. Windows disc wont repair.

                      Comment


                      • #12
                        same problem... and I just got my 910xt... I can't upload the workout..

                        Comment


                        • #13
                          same here... please fix! Using IE10 in the interim.

                          Comment


                          • #14
                            Saw on their twitter feed @garminconnect on 29th Oct that it was at least reported as a problem, but no ETA

                            Comment


                            • #15
                              Same issue

                              I have the same issue, except I have no problems uploading my training files to Garmin connect via automatic or manual upload from the device (910XT or Edge705).

                              Discovered the problem when I tried to upload mew heart rate zone data to both devices.
                              Temporarily switched to Firefox which worked fine.

                              In fact that's odd. Why do things work in FF and not in Chrome if it's Garmin who changed something recently. I have the feeling the error is related to Google Chrome and the way it interacts with Windows 8.

                              Comment

                              Working...
                              X