Announcement

Collapse
No announcement yet.

Unable to sync / connect 735xt to Garmin express via USB

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Unable to sync / connect 735xt to Garmin express via USB

    Hi
    i have seen a previous thread regarding this and wondered if there was any potential resolution available or whetther i should simply make a warranty claim.

    symptoms:-
    • PC does not recognise watch as mass storage device or load the USB drivers (when connected via the USB cable).
    • Watch face freezes on the USB connected screen after cable disconnection and takes significant time to return to normal.
    • Garmin express does not find the watch / cannot sync or download updates.
    • Garmin connect on iphone (via bluetooth) works fine.
    • Stand-alone watch function is fine - other than this issue love the watch
    Ive tried both the published tactics such as:-
    • Deleting from Garmin Express and trying to re-add
    • Forcing the watch into mass storage mode (PC does then recognise the watch is connected but only partially)
    • Tried on other PC's and same problem.
    Interested to know others experience or Garmin Joey's advice.

    Thanks

    Dom

  • #2
    Hi Dom,

    If you are not able to force the device into mass storage so that Garmin Express recognizes the Forerunner 735XT, and you are seeing the issue on multiple computers, it is probably best to reach out to Product Support. Could be an issue with the cable or may require looking at an exchange.
    Garmin Product Support

    Visit the Support Center
    www.garmin.com/support

    Comment


    • #3
      Same for me but with forerunner 630

      Comment


      • #4
        Thanks Garmin-Joey - I'll progress this through Garmin support channels

        Comment


        • #5
          I contacted Garmin UK support today and it appears that i will have to wait 6 weeks for a repaired watch (not guaranteed). Is this normal / acceptable?

          Any similar experiences?

          Comment


          • #6
            Hi Dom, exact same problem just occurred for me today also, except on a MacBook Air - no mass storage device shows up on desktop; watch shows it is charging but locks up on charging window after removing usb cable - 20sec power button reset required; time seems to stop. Watch works fine by itself once reset and time resyncs via GPS. Have tried forcing watch into mass storage mode but nothing happens at all.

            Comment

            Working...
            X