Announcement

Collapse
No announcement yet.

Unable to import Fitbit data -- An error occurred with your upload. Please try again.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Qutory View Post
    I also had the same problem. Same error message. I opened the file the fitbit was generating and the format is not correct. So just as IANW555 did, I fixed the file and the upload worked. However I still don't see the imported data in garmin connect.

    For how to fix the fitbit files:
    The .csv stands for Coma Separated Values. This means that the file can have one line of header names and then the rest of the lines should be values separated by coma. The problem is that fitbit is adding a "category" name on the first line then the headers on the second which turns the file in an invalid format. So in order to fix this you should delete the first line which should contains either "Body" or "Activities". Also don't export files containing multiple categories from fitbit as they will be exported in the same style and you need to make more cleaning and separate the exported files in two separated ones anyway. I higlighted the values you would need to remove from the body export. You can open them in a text editor or a spreadsheet (like excel or google sheets).
    For what it's worth, what you're describing is a little different than what IANW555 said he did. He said he manipulated the FitBit export file "by putting on a single line and adding missing commas." Presumably, the "missing commas" would be in place of the line breaks. What you are describing, on the other hand, is actually taking Fitbit's file and making it a "proper" csv.

    The interesting thing is that the import tool worked "successfully" in both cases, although nothing was actually imported (again, in both cases). Unfortunately for me, neither of those methods work. I still get the error message every time. I even tried converting from Fitbit's default UNIX line endings into DOS line endings. That didn't work either.

    So to summarize the issue
    • The Garmin import tool specifically claims to accept "FitbitĀ® body or activity data (.xls, .xlsx or .csv format)" but it generates an error when you try to give it that.
    • This worked at one point, which implies that Fitbit changed the format of their exported file at some point and Garmin has not been able to keep up.
    • Some people have been able to manipulate the csv such that Garmin will accept it and not give the "An error occurred with your upload. Please try again" message.
    • The above does not work for everyone (at least not for me).
    • When the above manipulation does "work," it still doesn't result in the data actually appearing in Garmin Connect.
    • This import feature was introduced in November 2016 and has been broken since December 2016.


    That last part is pretty shameful on Garmin's part. Importing data from a CSV file (even if the file isn't formatted well) is not rocket science. Fixing this problem should be an hour or so of work, tops. Not 5 months (and counting).

    Between that and this Garmin is off to a pretty poor start in my eyes.

    Comment


    • #17
      Originally posted by demarcmj View Post
      I have a Withings scale that I have synced with MyFitnessPal and it makes it's way to Garmin. It doesn't transfer historical data, mind you. I set it up a couple days ago and the data has been showing up in Garmin ever since. So I expect it would work with your Fitbit scale. If MyFitnessPal accepts that data, I don't know why it would handle it any differently than it does weight data from a Withings scale.

      It only transfers weight though, which is a bit of a bummer. Not any of the other data that scales measure these days. Oh well.
      I can confirm that my Fitbit scale data is syncing to Garmin through MFP. Once again, that appears to be the only thing that is syncing. I've been able to import Fitbit's .csv export of "Activities" but not "Body". Very frustrating. IMHO, either offer a solution or don't. Don't leave the option available if it's broken with no sign of repair.

      Comment


      • #18
        It seems like Garmin may actually be working on the issue...

        As of last night, "activities" import was finally working for me. I exported just activities from Fitbit, as a csv, and then imported it into Garmin and my steps and what not were all there. Before the feature broke again, I exported and imported all of my Fitbit data going back to July 2015 when I started using Fitbit.

        Some notes...
        • XLS did not work, only csv
        • I didn't have to modify the csv file at all
        • You have to do "activities" and "only" activities. Body data seems to still be broken.


        One thing to keep in mind for people who are getting a success message but their steps aren't showing up...
        When Garmin asks you for the date format, open the csv in a text editor to see what is in your file. If you open the csv in Excel, Excel may show the date in a different format than is actually in the file.

        Comment


        • #19
          Hi
          can you attach one of the cvs files which worked?
          thanks
          Norman

          Comment


          • #20
            Originally posted by Screetch82 View Post
            Hi
            can you attach one of the cvs files which worked?
            thanks
            Norman
            Here you go...

            fitbit_export_201609.csv

            Exactly as it came out of Fitbit. No modifications needed.

            Note: As I mentioned in my earlier post, be careful when you answer the date formatting question. Excel will show you something different from what is really in the file, as shown in the picture below. I imagine this may be the reason some people had "success" messages but didn't see any steps on the days they expected.

            Comment


            • #21
              awesomeq

              That worked, thank you. I imported this years steps and distances
              I wish i could do the same with sleep data

              Comment


              • #22
                This is ridiculous i think I imported my old data like 3 times thinking it failed and I might have tripled my activity.

                I am going to email Garmin help directly

                Comment


                • #23
                  I think I have found a solution to the problem outlined on this thread. Messaged it to Garmin Facebook but they haven't replied in a few weeks. Haven't been able to post in the forums either. :/

                  I was messing around with a few csv files, some of which worked and some of which didn't, looking for anything that differed between the two. I found that files dated 18-05-2017 and later did not import while older records did. When comparing I noticed that after this date, the FAT column began being expressed in three decimal points instead of one or two like it had been previously:

                  Body
                  Date,Weight,BMI,Fat
                  "26-07-2015","67.11","22.17","13.1"
                  "27-07-2015","67.03","22.14","13.1"
                  "28-07-2015","66.95","22.11","13.1"
                  "29-07-2015","66.87","22.09","13.1"
                  "30-07-2015","66.79","22.06","13.1"
                  "31-07-2015","66.71","22.03","13.1"
                  "01-08-2015","66.63","22.01","13.1"
                  "02-08-2015","66.55","21.98","13.1"
                  "03-08-2015","66.47","21.95","13.1"
                  "04-08-2015","66.39","21.93","13.1"
                  "05-08-2015","66.31","21.9","13.1"
                  "06-08-2015","66.23","21.87","13.1"
                  "07-08-2015","66.15","21.85","13.1"
                  "08-08-2015","66.07","21.82","13.1"
                  "09-08-2015","65.99","21.8","13.1"
                  "10-08-2015","65.91","21.77","13.1"
                  "11-08-2015","65.83","21.74","13.1"
                  "12-08-2015","65.75","21.72","13.1"
                  "13-08-2015","65.65","21.68","13.1"
                  "14-08-2015","66.35","21.92","13.1"
                  "15-08-2015","66.05","21.82","13.1"
                  "16-08-2015","65.75","21.72","13.1"
                  "17-08-2015","65.3","21.57","12.97"
                  "18-08-2015","65.19","21.53","12.848"
                  "19-08-2015","65.01","21.47","12.845"
                  "20-08-2015","65.81","21.74","13.022"
                  "21-08-2015","64.82","21.41","11.397"
                  "22-08-2015","65.25","21.55","12.397"
                  "23-08-2015","65.96","21.78","12.375"
                  "24-08-2015","66.66","22.02","12.352"
                  "25-08-2015","65.96","21.79","12.003"

                  When I changed these values manually to only consist of two decimal points, the files imported correctly. The date of the errors corresponding to (post-18/08/2015) would line up with when I started using the Aria, hence the more-detailed values for the FAT field.

                  This solution now provides me with a graph or Weight, BMI, and Body Fat

                  Comment


                  • #24
                    Also of interest may be this post for getting activity files from FitBit to Garmin Connect. It worked for me with a teensy bit of research of how to use Microsoft Powershell:

                    https://forums.garmin.com/forum/into...garmin-connect

                    Happy to answer questions if anybody needs help doing it.

                    Comment


                    • #25
                      Unfortunately I still can't get the "body" files to import, regardless of data massaging. I've almost finished hand-jamming everything so soon it won't matter to me. I'm glad you had some success.

                      Comment

                      Working...
                      X