Announcement

Collapse
No announcement yet.

Forerunner 25 sync via Bluetooth issue

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Forerunner 25 sync via Bluetooth issue

    I have an issue when my forerunner25 and garmin connect app android are paired via Bluetooth-when I sync those devices it is shown that sync was performed but my new data are not transferred to the application. It is happening for about a month now, in the meantime I updated watch as well as app.
    Few weeks ago I succeeded to sync new workouts via Bluetooth after I unpaired those two devices, then paired them again, before I deleted cached data... I tried the same again but without a success. Anyway that is not a permanent solution, it should be working smoothly.
    Every time sync line is green, but no new data are transferred to the app.

    I noticed some similar problems on forum, but haven't find the exact solution to my problem.
    Thanks in advance for help.

  • #2
    My wife's having the same exact problem syncing from her new FR25 to Connect running on an iPhone 6. Bluetooth connection seems instantaneous, it acts as if it's syncing, but no run data is transferred.

    She's unpaired and re-paired countless times but is yet to successfully upload runs without a USB connection.

    Feels like a software issue rather than a problem with the unit, as otherwise surely there'd be errors in the sync process.

    Comment


    • #3
      This exact issue happened to me all the time with my Galaxy S4, had to try several times, with some un pairing a re pairing in between, before successfully sync the activity.

      Comment


      • #4
        Have tried unpairing and re-pairing several dozen times - it's not syncing any run data.

        Tried logging in to the app on a different iPhone - same issue.

        Is it worth trying to downgrade the firmware on the watch?

        Comment


        • #5
          Scratch that - have tried downgrading to 3.13 on the device and it still won't sync run data.

          Comment


          • #6
            Same issue, fr25 , shows synced, but nothing is transferring on Android app. I'm on Android n beta, Nexus 6p.

            Comment


            • #7
              Cracked it, sort of.

              For us it was seemingly a case of removing old Garmin devices from Connect and then trying again. Weird because I have two devices linked to Connect on my own phone (FR10 and 620) with no issues.

              But this was with firmware 3.13 running on the FR25. I've just updated back to 3.30 and it's stopped working again!

              Comment


              • #8
                Tentatively optimistic now.

                Deleted the FR25 from Garmin Connect on a PC while hooked up via USB. Then deleted the device from Garmin Express. Also deleted the watch from the app.

                Re-added it through Express, which then got picked up by Connect on the PC. Filled in all info such as data fields, km or miles, tones on or off etc.

                This time, we left activity tracking on (even though it's a feature my wife doesn't want). Then we synced via Express and detached it from USB.

                Re-paired with the phone, did a test activity, synced - successful right off the bat.
                Turned activity tracking off on the watch, tried another test activity - successful again. This is the first time we've had two consecutive successful syncs via Bluetooth since it was bought.

                Touch wood it is now working as advertised.

                Comment


                • #9
                  So summarizing: you deleted the device from all platforms and then added it again and that sort of solved the syncing problem?

                  Comment


                  • #10
                    Originally posted by betolozada View Post
                    So summarizing: you deleted the device from all platforms and then added it again and that sort of solved the syncing problem?
                    I think getting other devices off all platforms might be key as well - Connect thought it was syncing, but clearly wasn't. Could never see a setting for it, but maybe other devices (in this case an FR10, a non-Bluetooth watch) were seen as the one from which to take run data. Without those in the way anywhere on the system, it started working properly.

                    Comment


                    • #11
                      My wife's FR25 has experienced this same issue with her iPhone 5S. For unknown reasons, the bluetooth connection drops. Trying to get it to re-connect does not work until the device is removed from Garmin Connect on the phone and from the list of bluetooth devices on the phone (the FR25 is her only device connected to her phone's bluetooth). Basically, we install/connect it as a new device each time this occurs.
                      Last edited by Rerun201; 08-28-2017, 05:13 AM. Reason: grammar

                      Comment


                      • #12
                        My FR25 drops bluetooth as well. I tried removing my FR25 and adding it to no avail. Restarted the watch and my iphone and that did the trick.

                        Comment

                        Working...
                        X