Announcement

Collapse
No announcement yet.

White screen after login to Garmin connect

Collapse
X
  • Time
  • Show
Clear All
new posts

  • White screen after login to Garmin connect

    Hello

    Yesterday i create account on Garmin Connect.
    But after login i see only white screen with menu
    I have Garmin Fenix 3 and i also try login via Garmin Express. But after login, app show error like this: Garmin server is out available.

    Do you have anybody this issue like me?

    thanks


  • #2
    This is generally due to something in your system blocking the download. Could be your av, pop up blocker, your browser etc so try a different browser, settings on your pop up blocker etc
    Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
    Previously owned Etrex Legend H, Mio Navman and used Mapsource
    (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

    Comment


    • #3
      I ty 3 PC at home and 2 PC at work. But i have still same issue .I also try login via mobile phone. But it is still same

      Comment


      • #4
        Then call Garmin Support for help. There may be an issue with your account
        Currently own Drive 50LMT-D, Nuvi 2508LMT-D, Nuvi 1490LMT, Nuvi 1310, Montana 650T, Etrex 20, and use Basecamp, OSM mapping
        Previously owned Etrex Legend H, Mio Navman and used Mapsource
        (please note that I am not employed by Garmin, but am a long term user of Garmin software and hardware)

        Comment


        • #5
          I'm facing the same issue
          I've tried 3 different Operating systems along with Firefox, Chrome, IE and Edge and I still can't see my dashboards
          Any idea?

          Comment


          • #6
            Me too! I have the same loading error and see exactly the same as the OP; and I can't imagine that it is down to pop-up blockers if the page shell is loading. I've tried on three browsers, all with any blockers turned off and it doesn't load. More interestingly, the page has loaded happily on this particular computer for over five years, both for my login and that of my wife.

            But today it didn't. That sounds more like an upgrade at Garmin's end that needs tweaking. I don't recognise the "connect.garmin.com/modern" URL so there must be a bug in the code that launches to my my own dashboard page.

            I'm going to give it 24 hours to see if Garmin can correct it themselves.

            Comment


            • #7
              Originally posted by alielmeshmeshy View Post
              I'm facing the same issue
              I've tried 3 different Operating systems along with Firefox, Chrome, IE and Edge and I still can't see my dashboards
              Any idea?
              I've tried it on Safari and Opera and get the same view as you do. And I've had a Garmin Account for over 5 years so it's not to do with your new account.

              Comment


              • #8
                I’m getting same white screen using Safari on MacBook. Data visible on GC Mobile on iPad (iOS), and head still syncs on cable to MacBook.

                Comment


                • #9
                  Have just spent 40 mins on chat with support and they don't know what the problem is. I've even tried to load the site onto Google Chrome on a Windows laptop and was told that my browser is not supported by Connect and that I need to upgrade, even though I am running 3325.181 which is the very latest Chrome version released in March.

                  There's something wrong with Connect and Garmin aren't telling us what that problem is!

                  Comment


                  • #10
                    Same problem here... for the past few days there is no way to get data and dashboards in Garmin Connect, doesn't matter the browser or the account, basically it doesn't work. Is there any update from support???

                    Comment


                    • #11
                      Support are denying there is a problem and claiming that it is a fault caused by our browser settings. I'm disappointed by the lack of interest shown by Garmin to what is clearly a technical fault: either an upgrade has missed a line of code or has failed to include certain browser compatibility.

                      Comment


                      • #12
                        I've got my data back - my usual dashboard is visible!

                        Comment


                        • #13
                          Problem has returned, white screen instead of dashboard... :-(

                          Comment


                          • #14
                            I have this exact problem too - has anyone found a solution?

                            Comment


                            • #15
                              Same issue White screen not loading any dashboards.

                              Comment

                              Working...
                              X