Announcement

Collapse
No announcement yet.

Connect showing wrong time zone for activities

Collapse
X
  • Time
  • Show
Clear All
new posts

  • Connect showing wrong time zone for activities

    So my GPS runs are still being uploaded in the wrong time zone. Everything is correct on the watch itself. I'm in NY and all my runs are showing up on Connect as being in the Colombia time zone. This is causing the times for all my runs to be an hour behind. Not a big deal but no reason why it shouldn't be correct.

  • #2
    Is your time in Garmin Connect set properly? On the Garmin Connect main page, click on the head and shoulder icon (right side) and choose Settings and check that the time zone is properly set for NY.

    Comment


    • #3
      I believe it is. Under Settings, Display Preferences it is set to Eastern Time for US. All my runs do show up as New York City runs so the watch (FR 235) does know where I am. When I check the activity history on the watch it has the correct times listed which makes me think it is a Connect issue.

      Comment


      • #4
        On the drop down menu for choosing the upload time zone, it says that Eastern time zone is GMT -5:00. This is incorrect. Right now with daylight savings we are GMT -4:00. The Colombia time zone is still GMT -5:00. This might be confusing the system and causing it to show my times 1 hour behind. Seems strange that this problem would only affect me. Is there anywhere else on Connect where I can select the time zone? Would love to hear any thoughts.

        Comment


        • #5
          It seems you have the right settings; I am also in the Eastern Time Zone, DST is recognized, and I do not see the issue you are reporting...

          Comment


          • #6
            So when you go to that drop down menu, all the GMT times have taken into account DST?

            Comment


            • #7
              No it's says GMT -5:00 but the transfer time takes into account DST and is right (and changed properly back in March when we changed time)...

              Comment


              • #8
                Very strange. Something must be up with my profile but I don't think there's anyplace else to change the setting.

                Comment


                • #9
                  I have the same issue, GC also shows Colombia time zone, but I am in EST in Florida.

                  Comment


                  • #10
                    I also (and at least one other) have activities upload to Garmin Connect with the wrong time zone. One will be correct (Central Australian time). Another ride recorded the same day will be incorrect and will be Japan Standard Time. The difference is southern latitude version northern latitude. In your case, northern latitude versus southern.

                    Annoying, but the activity is recorded correctly on the device and uploads to Strava and Training Peaks correctly, so yes the problem is in Garmin Connect.
                    Current:
                    Garmin Edge 520, Forerunner 935

                    Previous:
                    Forerunner 230, Polar RCX5 Tour de France, M450, V650, RS300X, M51, Favor

                    Comment


                    • #11
                      I have a similar problem. I'm in the Eastern time zone, but occasionally my 220 puts me in the Central time zone. Not the 225 and not the Edge, just the 220.

                      Comment


                      • #12
                        Still experiencing this issue. I definitely have the Eastern Time Zone selected as my upload time zone yet it is still putting all my activities in the Colombia time zone.

                        Comment


                        • #13
                          I rode to work last Friday and still have the same problem. Morning ride okay (Central Australian), afternoon ride incorrect time zone (Japan).

                          It's Garmin connect only. For me, Strava, Training Peaks, MyFitnessPal, Fitbit (via MyFitnessPal) are all correct and are receiving the same data from Garmin Connect.
                          Current:
                          Garmin Edge 520, Forerunner 935

                          Previous:
                          Forerunner 230, Polar RCX5 Tour de France, M450, V650, RS300X, M51, Favor

                          Comment


                          • #14
                            I bought my Vivosmart HR+ last week and had the same problem with the time zone being off. In my case, it was off by 4 hours behind. That is, starting an activity at 11:00 AM (CDT) would appear as if I had started it at 7:00 AM. After triple-checking that the "Upload Time Zone" on the Connect website (Settings >> Display Preferences) was set correctly to "GMT-06:00 Central Time (US & Canada)", I finally called Garmin Support.

                            It turns out that my Garmin device was set to "Set Time Manual". Once I changed it to "Set Time Auto", my new activities are showing up with the correct time zone.

                            Furthermore, to edit activities in the past to correct the time, I read elsewhere on these forums that you can go to the Connect website and then go into the Activities dashboard. From there, click on an Activity you wish to change. Then, in the upper right-hand corner, there is a Pencil icon that allows you to edit the Activity, which will allow you to edit the Start Time.

                            Comment


                            • #15
                              johnh

                              Originally posted by rugby4all View Post
                              Is your time in Garmin Connect set properly? On the Garmin Connect main page, click on the head and shoulder icon (right side) and choose Settings and check that the time zone is properly set for NY.
                              I have same problem using a Garmin 510. I live in New Zealand. At moment we are GMT+12 but time on Connect page shows I start activity an hour earlier - in fact if I put my cursor over the time it says "Fiji time" but My Garmin 510 time is set correctly to local time. It also shows up incorrect on phone app after auto upload

                              Comment

                              Working...
                              X